Lightroom 4 not setting original filename properly when renaming in import dialog.

  • 3
  • Problem
  • Updated 1 year ago
  • Acknowledged
As the topic says, when doing a rename during import, LR will set the 'original filename' field to the NEW name - not the original as on the card.
If you import THEN rename, the original filename is as it was on the card.

If it was being correctly done during import, it would make renaming files much easier via using the 'original filename', 'original suffix' tags in the rename dialog.
As it stands now, I must do that in 2 steps in order to preserve the original filename. The problem comes when forgetting to do the manual rename after import - making filenames inconstant and hard to find which ones weren't renamed due to all the various original filenames - AND the fact that a smart collection can't search for a 'filename starts with' using only 1 letter (i.e. P801453.ext).

PLEASE, oh PLEASE get this fixed SOON! It's getting SO annoying to have to do renaming in 2 step like this. (Plus the fact that I have a condition that makes it REALLY easy to forget things. :-/ )
Photo of Chris

Chris

  • 47 Posts
  • 3 Reply Likes
  • frustrated

Posted 5 years ago

  • 3
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 104 Reply Likes
Thanks for reporting this. I have logged a bug.
Photo of Douglas Ansel

Douglas Ansel

  • 8 Posts
  • 0 Reply Likes
It's been two years - this bug is still present in Lightroom 6/CC.
Is there any fix for this? I just had an entire photoshoot get royally screwed up because of this bug, and i'm feeling extremely frustrated to find out you've known about this for more than two years...
Photo of Chris

Chris

  • 47 Posts
  • 3 Reply Likes
Might this ever get fixed??
4 years and counting....................