Lightroom 4.4.1: "Edit in PS CS6" with sRGB configured opens in ACR color space instead

  • 3
  • Problem
  • Updated 5 years ago
This is a strange one: When opening a Raw in LR 4.4.1 in PS CS6 ("open in PS CS6..."),the color space in the LR settings for "edit in PS" is sometimes not correctly transferred to PS. This depends on which default color space is set in Photoshop's Camera Raw (which should normally have absolutely no influence in this case).

E.g., when Camera Raw is set to AdobeRGB:
PSD, sRGB, 8Bit => opens in AdobeRGB (NOT OK)
PSD, AdobeRGB, 8Bit => opens in AdobeRGB (ok)
PSD, ProPhotoRGB, 8Bit => opens in ProPhotoRGB (ok)

When Camera Raw is set to ColorMatchRGB:
PSD, sRGB, 8Bit => opens in ColorMatchRGB (NOT OK)
PSD, AdobeRGB, 8Bit => opens in ColorMatchRGB (NOT OK)
PSD, ProPhotoRGB, 8Bit => opens in ProPhotoRGB (ok)

When Camera Raw is set to ProPhotoRGB:
PSD, sRGB, 8Bit => opens in ProPhotoRGB (NOT OK)
PSD, AdobeRGB, 8Bit => opens in ProPhotoRGB (NOT OK)
PSD, ProPhotoRGB, 8Bit => opens in ProPhotoRGB (ok)

Only if Camera Raw is set to sRGB, all different settings in LR work OK (e.g. sRGB and AdobeRGB). It seems that the resulting color space is the larger one of the two configured in LR and PS-ACR. Edit: The conversion to the actual profile seems to be OK, i.e. the colors are correct. It is "just" the wrong profile.

I use LR 4.4.1 64 Bit and PS CS6 64 Bit 13.0.1 with ACR 8.1.0.43 on Windows 7. Photoshop's color settings are: RGB working profile: sRGB, color mgt. policy for RGB is "keep profile", different profiles: Don't choose on open, choose on paste, missing profiles: choose on open (translated from German). However, the color settings don't seem to be part of the problem.

Note: This bug seems to be fixed in LR 5 (5.0 final, with the same CS6), so it seems to be Lighroom's fault, and not Photoshop's. However, it is still very strange that the ACR color space setting has any influence on this, *and* that this depends on the LR version.
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes

Posted 5 years ago

  • 3

Be the first to post a reply!