Lightroom: 4.3 Cannot use Slideshow, get "An error occurred when attempting to change modules"

  • 13
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Lightroom 4.3 on MacBook Pro Retina + Cinema Display: Cannot use Slideshow, get "An error occurred when attempting to change modules". OS X 10.8.2, 16Gb, 2.7 GHz Intel Core i7. Approximately 30 seconds from installation to finding this bug.
Photo of Kevin Tureski

Kevin Tureski

  • 4 Posts
  • 2 Reply Likes
  • frustrated

Posted 7 years ago

  • 13
Photo of Alexey Timanovsky

Alexey Timanovsky

  • 11 Posts
  • 1 Reply Like
Workaroud is to first launch lLightroom and then attach secondary monitor.
Photo of Greg Fridman

Greg Fridman

  • 1 Post
  • 0 Reply Likes
Worked for me, thanks. But this is really annoying... :-)
Photo of Kevin Tureski

Kevin Tureski

  • 4 Posts
  • 2 Reply Likes
Sorry, Alexey, I have seen that suggestion elsewhere and it is not working for me.

I rebooted (without the second monitor), tried Slideshow and it worked. Quit Lightroom, connected the second monitor, launched Lightroom and immediately got the same error (because it was still in Slideshow mode). I also tried making sure that Lightroom was in Library mode before quitting when the secondary display was not hooked up, then starting Lightroom but again, going into Slideshow mode generates the same error.

Adobe QA please note the ease with which this can be reproduced.
Photo of Jason MacLeod

Jason MacLeod

  • 1 Post
  • 0 Reply Likes
Hi,

I am seeing this issue too. Mac Mini with two HP displays. It would be great to get a response that this is known as an issue and is being looked at as a bug. I work with two monitors as my default setup, so the workaround of detaching/reattaching monitors is no good. It (monitor fiddling) is so disruptive that I didn't try it. Probably the best workaround is to roll back from Lightroom 4.3 if that is possible for you. I will try that.

thanks,

Jason MacLeod
Photo of Alexey Timanovsky

Alexey Timanovsky

  • 11 Posts
  • 1 Reply Like
Hi Jason, upvote this bug please - there is a button on original message.
Photo of Tord Lindner

Tord Lindner

  • 6 Posts
  • 0 Reply Likes
I got it with the upgrade to LR 4.3. I've cleaned out all parameter files (com.adobe.Lightrrom.plist) etc, deleted the app and all files I found, installing a fresh LR4.3 gives the same error. Downgrading to 4.2 and it all works again.

Creating a new user and then start LR4.3 the slideshow works (?). I've tried to copy all parameter files form the new user to my account but it still doesn't work. Since LR4.3 does work on a fresh account it must be something with a parameter files somewhere. I've three monitors hooked up (the third through a USB-DVI box)
Photo of Richard Brooker

Richard Brooker

  • 2 Posts
  • 0 Reply Likes
Since updating to Lightroom 4.3, I cannot access the Slideshow module. Each time I try, I receive the following message:

"An error occurred when attempting to change modules."

I have researched the problem and have followed instructions I've found to resolve the issue including:

replacing the preferences file (com.adobe.Lightroom[VERSION#].plist) and deleting my user created slideshow templates.

The problem still persists.

This reply was created from a merged topic originally titled
Lightroom 4.3 update Slideshow module error.
Photo of Richard Brooker

Richard Brooker

  • 2 Posts
  • 0 Reply Likes
Unplug and reattach displays; create new profiles...what the frig???

None of these things work and/or are terribly inconvenient.

This is a real problem~! HELLO...fix this please!
Photo of Bailey Cooper Ltd

Bailey Cooper Ltd

  • 1 Post
  • 0 Reply Likes
Same problem with two monitors attached. Tried all suggestions and the only solution that worked is disconnecting the 2nd monitor. Not ideal during a busy day!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
The team is looking into this. Thanks.
Photo of pavel.pola

pavel.pola

  • 19 Posts
  • 3 Reply Likes
Hello, I have the same problem. Everytime I click Slideshow, I get this error message. I have tried this with empty Catalog and it didn't work. So there must be some error in the App itself.
Photo of thomas varley

thomas varley

  • 1 Post
  • 0 Reply Likes
Hi, Had same problem. I couldn't find a fix after a few hrs so deleted Lightroom 4.3 & reinstalled Lightroom 4.2 & I'm back in business again.
Photo of mitch prout

mitch prout

  • 1 Post
  • 0 Reply Likes
OK.... well where can i download lightroom 4.2 to get it working again?!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
Photo of Walter McCarthy

Walter McCarthy

  • 1 Post
  • 0 Reply Likes
There's more on this thread in Lightroom's forum:

http://forums.adobe.com/thread/111589...
Photo of Tord Lindner

Tord Lindner

  • 6 Posts
  • 0 Reply Likes
what's going on? how long do we need to wait until there is a fix or a work-a-round? Has this even got an official ticket, are Adobe working on this?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4971 Posts
  • 1932 Reply Likes
It's marked as In Progress, so yes they're working on it. Hopefully it'll be fixed in 4.4, but you can roll back to 4.2 for now if it's causing a problem in your workflow. Just uninstall 4.3 and install 4.2 again. You'll find the download links by googling "Lightroom 4.2 download".
Photo of Tord Lindner

Tord Lindner

  • 6 Posts
  • 0 Reply Likes
Need 4.3 for my camera support. I can't see anything about this in the 4.4 release note :(
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
This should be fixed in 4.4.
Photo of jtByt.Pictures

jtByt.Pictures

  • 2 Posts
  • 0 Reply Likes
The slideshow module in LR 4.3 doesn ́t work.
When I click on "slideshow" or "book" there is a dialog window telling me, that there is an error at trying to switch between the modules. Ok button, nothing else happens, grey instead of the module.

I ́m using LR 4.3 on Mac OS 10.8.2

I tried the last Version of LR, but there ́s everything ok.
A reinstall of LR 4.3 doesn ́t help.

Please help/ fix this problem.

This reply was created from a merged topic originally titled
Lightroom 4.3: error switching to slideshow module.
Photo of Fritz Fischer

Fritz Fischer

  • 1 Post
  • 0 Reply Likes
I installed Lightroom 4.4 RC. The Problem is still there. Nothing is fixed.
Photo of Tord Lindner

Tord Lindner

  • 6 Posts
  • 0 Reply Likes
I gave up, I made a complete re-build of 10.8 and did a fresh install of LR4.4 and now it works.
Photo of Tord Lindner

Tord Lindner

  • 6 Posts
  • 0 Reply Likes
I was very nervous upgrading to 4.4 now when I finally got 4.3 working (rebuild OSX 10.8). All in - and it works even after upgrading to 4.4 :)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
Official Response
Thanks for reporting this. This issue should be fixed in Lightroom 4.4. Choose Help>Check for Updates... to download and install.
Photo of Milo Garber

Milo Garber

  • 5 Posts
  • 0 Reply Likes
hah .... upgraded to 4.4 .... slideshow works but only on 2nd monitor (which is not my primary monitor
Photo of Milo Garber

Milo Garber

  • 5 Posts
  • 0 Reply Likes
Come on guys....the option to play slide show on the primary monitor in slide show module is now missing in 4.4. This is really disappointing. What's up....
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4971 Posts
  • 1932 Reply Likes
I can't reproduce here Milo. Can you confirm system specs please?
Photo of Milo Garber

Milo Garber

  • 5 Posts
  • 0 Reply Likes
Mac Pro early 2009
2.66 Ghx Quad Core Intel Xeon
32 GB
OS X10.8.3 (12D78)

the Playback Screen section in Slideshow shows no options other than "blank other screens"

thanks
Photo of Ricardo León

Ricardo León

  • 2 Posts
  • 0 Reply Likes
I am running Lightromm 5.6 and that message "An error occurred when attempting to change modules." appeared just after upgrading to Yosemite OS in my MacBook Pro. I just cannot get rid off it after every advice given in Adobe Forum...