Lightroom: 4.3 import from and to NFS mounted filesystem does not work

  • 1
  • Problem
  • Updated 5 years ago
  • Not a Problem
  • (Edited)
Hi

In Lightroom 4.3 I am not able to navigate to NFS mounted destinations (both for source and target as both are located on a NAS that is NFS mounted to my Mac).

N.B.: the Lightroom catalog itself is located on a local disk.
Photo of Carsten Stolzenbach

Carsten Stolzenbach

  • 4 Posts
  • 0 Reply Likes
  • frustated

Posted 5 years ago

  • 1
Photo of jdv

jdv, Champion

  • 728 Posts
  • 55 Reply Likes
Describe "cannot navigate to" in more detail. Are there failures or errors? Are you saying the app cannot browse there?

In my line of work, "NFS" is a fancy way of saying "will probably appear to work in some cases, but wait until you find all the obscure edge conditions."
Photo of Carsten Stolzenbach

Carsten Stolzenbach

  • 4 Posts
  • 0 Reply Likes
"Navigate to" means that I can access the root level directory of the mount point but not directories below.

Example: I want to import new pictures into my Lightroom library. The catalog file is stored locally while the image files are stored on an NFS exported directory on a file server. This NFS directory is locally mounted on /mount/lightroom. Below /mount/lightroom there are subdirectories like "settings" (/mount/lightroom/settings) or "files" (/mount/lightroom/files). I want to import the pictures to /mount/lightroom/files using the subfolder structure YYYY/MM-DD. Today's pictures would thus be imported to /mount/lightroom/files/2013/01-02. But do not get further than /mount/lightroom (with "files" being inviseble) and thus could only import to /mount/lightroom/2013/01-02.

In fact LR's import dialog shows the mounted directory on the right hand side as it would with a normal external disk. But when I want to open up the directories below by clicking on the triangel to the right of the name nothing happens.

Regardings NFS: all other applications I use are able to navigate into the NFS mounts and do even treat the mounted filessystem like a local one.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Which OS version are you using?

Since the open/save/import dialogs are provided by the OS, LR shouldn't even know what kind of filesystem it is using. So this would most likely be an issue with the OS or a filesystem driver.
Photo of Carsten Stolzenbach

Carsten Stolzenbach

  • 4 Posts
  • 0 Reply Likes
Ok, I think I found the source of this problem. It looks like either Mac OS or Lightroom are hiding OS generic directories like "/mnt" or "/Network" from the end user. In my example i wrote /mount/lightroom but in fact I had mounted the directory to /mnt/lightroom. If I really do mount it to /mount/lightroom I can dig into the subdirectories of the mounted filesystem as wanted.

So it seems only to be half a bug. ;-)

Thanks for help.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
MacOS hides a LOT of directories from the end user and expects you to navigate mount points from their desktop/drive controls and not the /mount or /volume directories.
Photo of Carsten Stolzenbach

Carsten Stolzenbach

  • 4 Posts
  • 0 Reply Likes
Yes, I know (now) :-(
Photo of Robert Brown

Robert Brown

  • 1 Post
  • 0 Reply Likes
I posted about this problem the other day here: http://forums.adobe.com/message/49697...

And I thank you for your help! I discovered that not only did I need to use a nonstandard mount point (I ultimately chose "/nas"), but that I also needed to mount with the "rdirplus" option (aka "Use ReaddirPlus NFSv3 feature"). I was using the German 3rd party package "NFS Manager" to help me mount and unmount quickly, while enabling and disabling options left and right to try to figure this problem out. It also allows me to specify it as an "automount". Prior to Mac OS X 10.8 (mountain lion), there was a GUI in Disk Utility to allow me to specify NFS mounts, but as of mountain lion, the button is gone, for reasons unclear.

Anyway, I got lightroom to navigate my NFS server by mounting on /nas, and by specifying the 'rdirplus' option in the mount command.