Lightroom: 4.3 hangs on import with Canon 5d mark iii

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
Help. I've tried everything!

I have a Canon 5d mark iii.
I'm trying to import photos into LR directly from the camera. This is what I've done for years with my old Canon Eos 50D.

Everything works great when I use Canon File Utility to transfer, then drag into LR 4.3.

But when I attempt to import in LR directly, it hangs in the middle and I have no choice but to restart LR.

I've tried isolating the issue. I've replaced the camera. I've replaced the SD card with a CF card. Nothing resolves this issue.

Is this a known issue with LR 4.3? I'm on mac OS 10.7.5
Photo of Dominique Igoe

Dominique Igoe

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13621 Posts
  • 1541 Reply Likes
Do you have an Android device attached as well? (phone/tablet)
Photo of Dominique Igoe

Dominique Igoe

  • 4 Posts
  • 0 Reply Likes
No other device besides a usb mouse and bluetooth keyboard.
Photo of Toby Silverman

Toby Silverman

  • 1 Post
  • 0 Reply Likes
I am trying to import from a folder on the desktop
I use an iMac
When I try, I get an error message that the raw format is not recognized

I have a brand new 5d mark iii
I have LR 4.3 loaded correctly

T silv