Lightroom: 4.2 constantly crashes when importing

  • 4
  • Problem
  • Updated 2 years ago
  • (Edited)
Recently installed Adobe Lightroom 4.2 on a Windows 7 Professional 64 bit system. I have a Synology DS 213 NAS which has approximately 25,000 potographs. I am trying to import them into a Lightroom 4 catalog. However LR constantly crashes!!!
Google Picasa never gave me any trouble!
Any suggestions? Where can I get a refund for this buggy software?
Photo of S S

S S

  • 2 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 4
Photo of S S

S S

  • 2 Posts
  • 0 Reply Likes
This is the windows problem signature that I get.
Thank you.

Problem signature:
Problem Event Name: APPCRASH
Application Name: lightroom.exe
Application Version: 4.2.0.11
Application Timestamp: 505a0579
Fault Module Name: AgKernel.dll
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 505a02fa
Exception Code: c0000005
Exception Offset: 0000000000024b52
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 3827
Additional Information 2: 3827030a6a21173052f15cdf92a7e852
Additional Information 3: 1c28
Additional Information 4: 1c28772cbd5d9b0606d9bfaef8da1caa

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linki...

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt
Photo of nacaron

nacaron

  • 4 Posts
  • 0 Reply Likes
FINALLY SOLVED!!!!!

After spending hours and hours searching, reading, trying, installing and uninstalling I solve my problem.

 

Name of the event problem:              APPCRASH

Name of the application:                     lightroom.exe

Version of the application:                  5.3.0.10

Mark of the time of the application:   529d013a

Name of module with errors:             dvamarshal.dll

 

This was happening every time I tried to import a certain amount of pictures, it just allowed me to import 5 or 6 at a time.

This is what I did, and worked for me:

 

1.    Download the file: “ dvamarshal.dll “ from  http://dllyes.com/dvamarshal-dll/​ 

2.    Go to C:\Program Files\Adobe\Adobe Photoshop Lightroom 5.3, or wherever you have the Lightroom installed, and rename the existing file; "dvamarshal.dll" to "dvamarshal1.dll"

3.    Copy the file downloaded from the link above, and paste it.

4.    Close the program, and restart the computer.

5.    Open the application as an administrator, and for me it worked!!!

 

Hope it helps :)

Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Hi SS,

Sorry to hear you are having this problem with Lightroom. Import is working as expected for me, so I'll need some more information from you to narrow down the cause of the problem.

First, as a test, try importing just one photo. If that works, try importing a single folder of photos. If importing a photo or one folder fails, check the folder and see if it contains any non-image files that might be tripping up Lightroom. It shouldn't be happening, but if you can narrow it down to a specific file or type of file, we can investigate further.

If importing from your NAS doesn't work at all, try importing a few photos from your local hard drive.

Another thing to try is disconnecting all USB and bluetooth devices from your computer during import (except the drive you're trying to import from, of course). We have seen occasional issues with import getting tripped up by a smartphone or ipod or faulty USB thumb drive. If you determine a specific device that seems to be a factor in the import problems, we'd like to know.

These are all just initial investigative steps to narrow down the cause of the problem and get Lightroom working for you.

Becky
Photo of Michael Sanders

Michael Sanders

  • 1 Post
  • 0 Reply Likes
Becky,

I had this exact problem yesterday.

My LR was crashing every time I tried to synchronize or import. After finding this link, I subsequently disconnected my Galaxy Note phone which was charging via a USB2 port, then LR was OK again. PC is an Acer M3985.

Michael
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Thanks Michael. The team was able to repro the problem with the Galaxy Note, and have logged a bug.
Photo of Rick Silvers

Rick Silvers

  • 3 Posts
  • 0 Reply Likes
for what it is worth...
I have lightroom 4.4 on Windows 7 and the combo of having a Samsung Galaxy S3 plugged in on the USB port for charging still causes lightroom crash immediately upon trying to start an import. I unplugged the phone the import dialog runs without issue.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14277 Posts
  • 1820 Reply Likes
Rick, can you please add your vote/comment to this thread: http://feedback.photoshop.com/photosh... I think this is the issue you are hitting.
Photo of Bud Lane

Bud Lane

  • 1 Post
  • 0 Reply Likes
Becky,
I purchased LR 4 about two months ago. It was working great and upgraded to 4.1 64 bit for my Window 7 machine. A few days ago it was working just fine, then I tried to open it yesterday and the nasty Windows message that is closing the program after I started the program. It loads the initial page and would load the last images I was working with, then Windows closed the program . Started and restarted my computer several times, same result. Downloaded 4.2. Restarted computer after download and the same message, even after a couple of restarts. There are no error messages or codes, just "adios partner" from Windows. How do I get my "Plug and Dud" back to "Plug and Play"?

Bud
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Bud, have you tried removing your Lightroom preferences before restarting? Its possible something in your prefs file was corrupted. Give that a try and let me know how it goes. You can find more info on locations for your prefs file at http://helpx.adobe.com/lightroom/kb/p...
Photo of Kosta Koeman

Kosta Koeman

  • 1 Post
  • 0 Reply Likes
What is meant by removing Lightroom preferences? I'm having the same issue. I did look at that link, but it is not clear to me what file I should "remove" and what remove means. Delete outside of Lightroom? Change something within Lightroom, etc.

Thanks.
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Kosta,

Here's what you need to do:
1. Quit Lightroom (if it is open).
2. Locate your preference settings file
Mac - The preference setting file is com.adobe.Lightroom4.plist and is in //Users/[user name]/Library/Preferences/

Win - The preference setting file is Lightroom 4 Preferences.agprefs, in C:\Users\[user name]\AppData\Roaming\Adobe\Lightroom\Preferences\.

3. Move the file to a different location (or put in the trash, but don't delete it).
4. Restart Lightroom.

If the problem goes away, then you know it was in the preferences file. Lightroom will build a new preferences file on launch, and reset your preferences to defaults.

Becky
Photo of Sasha K.

Sasha K.

  • 7 Posts
  • 0 Reply Likes
I have a similar situation. A big Windows 7 Professional 64 bit system - fast Intel chip, premium Intel made motherboard, 16GB memory, alll best practices installing and configuring. Large SSD for software and current projects. 4-bay NAS for near-online storage. Things generally run smoothly as silk, including Lightroom. Including import from cards via reader, or iPhone.

HOWEVER Lightroom is hiccupping and freezing when trying to import from a hard drive. It's doing that even as I type this. It does not crash actually, but sometimes it will take hours for it to come back when it is importing images from a hard drive. Import into the same catalog (big or small does not matter) from a memory card? Smooth as silk. Intel SSD? Or a fast NAS over gigabit? Huge delays and becoming unresponsive.
Photo of PerB

PerB

  • 1 Post
  • 0 Reply Likes
I'm having a similar problem when importing from a memory card. Lightroom freezes, sometimes it keeps working, sometimes it don't. It also loads incredibly slow which makes browsing images during import near impossible, import itself can go anything from reasonably fast to hardly at all. Doesn't matter if I'm importing a few images or a full card, except the full card takes forever to process.
Importing from hard drives or NAS works slightly better. No big issues with speed there, but I still get a lot of hickups with the import module itself. At first I suspected a defect card reader or USB cable but after a lot of testing and replacing of cables, the problem remains. Checked all my memory cards and can't see any difference. Tried my iPhone as well and get similar results.
I never had any problems in Lightroom 2 or 3, nor in the first version of LR4 either even though I noted a slightly drop in performance already in LR4 Beta and 4.0.

My system is a hig end Windows 8 Pro 64 bit, i5, Asus motherboard, 16GB RAM and a Corsair SSD.
I also use Lexar and SanDisk UDMA cards or equivalent, all 45 MB/s or better.