Lightroom 4.1 location metadata not being found in searches.

  • 1
  • Problem
  • Updated 6 years ago
In Lightroom 4.1 location metadata sometimes doesn't seem to be saved properly and can't be found in Library module searches. The metadata is present in the metadata panel in the Library and Map modules but is not found when searching (Using the all searchable fields text search). When the "copy metadata" command is invoked, the boxes are ticked but blank, rather than containing the metadata from the file which can be seen in the metadata panel.

I've had this problem with the GPS and IPTC location fields. It only effects some images, including JPG, CR2 and DNG file types. I have updated the metadata by applying a preset, in map view and in Library view all seem to create this problem more often than not. Reverse geocoding is not used, all values are applied manually. I can't detect any pattern to whether the location data will be available for searches or not.

I've tried saving the metadata to the file and then reading from the file but then the bug remains the location data for the effected image isn't searchable. I have tried closing and reopening lightroom, and switching to another library.

Exported images do contain the correct metadata. Deleting them from the library and importing the exported copy gets the Location metadata into Lightroom correctly, although this isn't feasible for large numbers of images.
I'm fairly sure that this is a bug, but perhaps I am doing something wrong with the workflow. It's a shame because I was hoping to shift from location based keywords to the combination of GPS and IPTC fields.

I am running Lightroom 4.1 64-bit on Windows 7 Home Premium.
Photo of Laurence Brown

Laurence Brown

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1

Be the first to post a reply!