Lightroom 4.1 Incorrectly Renders GPX Track Logs

  • 1
  • Problem
  • Updated 6 years ago
Bug: Lightroom 4.1 does not correctly render standard GPX track logs. Please see http://forums.adobe.com/message/44846... for a complete description of the issue along with sample data file.
Photo of Edwin Katibah

Edwin Katibah

  • 3 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 38 Reply Likes
The tracklog does not have timestamps. I guess that is what's confusing Lightroom. Not sure it's a bug or a design limitation.
Photo of Edwin Katibah

Edwin Katibah

  • 3 Posts
  • 0 Reply Likes
Yeah, I noticed that and wondered why. Still, timestames associated with individual locations (lat, lon) should have no impact on the spatial fidelity of the track itself. I'd argue that if this is "by design", it's a faulty design.

I'll explore the Garmin BaseCamp software to see if it has any options to export GPX with timestamps.

Thanks!
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 36 Reply Likes
Regardless of bug or design limitation, LR won't be able to automatically tag photos without a timestamp anyway.

Beat
Photo of Edwin Katibah

Edwin Katibah

  • 3 Posts
  • 0 Reply Likes
No luck in Garmin BaseCamp. I did, however, open the GPX file in TextWrangler and did a Search and Replace,

replacing

  </ele>

with

  </ele><time>2012-06-12T14:44:24Z</time>

The time is a non-changing, static value which I took from the time tag earlier in the GPX file. With this modification, Lightroom correctly rendered (!!finally!!) the GPX file.

I did try an even simpler

replace

  </ele>

with

  </ele><time></time>

tags but Lightroom choked on this structure.

You can see the new, correctly rendered GPS track log as 5th reply in the post:

http://forums.adobe.com/message/44868...