Lightroom 4.1 Develop module exposure keyboard shortcuts (+ and - keys) no longer work.

  • 3
  • Problem
  • Updated 3 years ago
  • Solved
With the final release of LR 4.1, using the + and - keys within the Develop module to adjust exposure no longer work. They appear to work, in that the app throws the expected dialog ("increase exposure +.10" or similar) and this action is recorded in the history panel, but the exposure slider on the right does nothing, and the expected result (up or down exposure) on the image never happens. With the + and - keys, you can send the exposure up or down 4 stops, per the history and the onscreen pop-up, but the adjustment actually never happens. Only when you use the mouse and drag the exposure slider up or down, does exposure actually adjust.

This is a tremendous workflow hit when you have thousands of images you want to make minor exposure adjustments to, and have to keep reverting to the mouse.

Everything worked fine (in this regard) in 4.1RC, and every version prior.

2010 Mac Pro
24G memory
Lion 10.7.4
Photo of Matt May

Matt May

  • 2 Posts
  • 0 Reply Likes
  • convinced Adobe has no ETS department.

Posted 6 years ago

  • 3
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 38 Reply Likes
Do you use PV2010 or 2012?

Looks like for some fields, the +/- keys only work in PV2012.
Photo of Matt May

Matt May

  • 2 Posts
  • 0 Reply Likes
Interesting... it is PV dependent. I can confirm the issue exists with PV2012 on LR 4.1, but not with PV2010.
Photo of GABRIEL TING

GABRIEL TING

  • 3 Posts
  • 1 Reply Like
Same problem as OP in LR4.1 on Mac 10.6.8. Huge issue.
Photo of TK

TK

  • 531 Posts
  • 111 Reply Likes
When someone fixes this, can they please also fix the issue with the missing keyboard flow control for the temporary eraser brush?

It occurs on Windows, not on a Mac. On a Mac it works. That's why it is a bug in the Windows version. Please fix it.
Photo of Kevin Long

Kevin Long

  • 9 Posts
  • 0 Reply Likes
The keyboard mapping part of this problem still exists and is not solved. I'm posting here but will also open a new problem specifically for this issue.
This has been a problem for many years, and across many releases of Lightroom. However, doing a BUNCH of digging, I finally discovered that to increase values in the develop module, you use an apostrophe s easy to fix, has been around for years, and is a pain in the rear. Needs a quick fix.
Photo of stephan mantler

stephan mantler

  • 4 Posts
  • 0 Reply Likes
In the current version of LR (on Mac, and presumably also in older or Windows versions, though I did not check) you can simply click on the 'Exposure' label to set it as the target for +/- keys. This also works for any other adjustment fields.

Double clicking to reset another field, adjusting sliders or entering numeric values for another field does not change this assignment; only single clicks on the label.