Lightroom 4.0 fails to recognize some images within a folder.

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
I've been using Lightroom for years. So I don't think this is a careless mistake on my part.

Lightroom 4 will not (at least in some cases) recognize files that need to be imported. EXAMPLE: I have a folder with 120 images in it. If I create a new Lightroom 4 file and set up an import of that folder's images, Lightroom only recognizes 99 of the 120 images.

HERE ARE THE STEPS I TOOK TO MAKE THIS HAPPEN: In Lightroom 4, I select a 21 TIFF images which are in a single folder. I do an EXPORT of those images, saving them as JPEGS into the same folder is the original TIFF images. Now, if I try to get Lightroom to Import those newly created JPEGS, Lightroom doesn't see them. If I attempt to synchronize that folder, Lightroom doesn't see the new JPEGS. If I look in the Finder, the newly created JPEGS are there. If I create a NEW Lightroom file and attempt to import that folder, only the original 99 images are recognized but no the newly created 20 JPEG images.

Any theories?

Lightroom 4.0
OS X 10.7.3
Photo of Dave Burbank

Dave Burbank

  • 4 Posts
  • 1 Reply Like
  • confused

Posted 6 years ago

  • 1
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 38 Reply Likes
It might have something to do with either duplicate recognition or Raw+Jpeg settings.

1) Did you uncheck the "Ignore duplicates" option in Import?

2) Try checking the "Treat Raw and Jpeg as separate files" option in Prefs.
Photo of Jim Wilde

Jim Wilde

  • 136 Posts
  • 26 Reply Likes
You've probably got "Treat JPEG files next to raw files as separate photos" unchecked in your LR Preferences (General Tab). LR sees the Tiff and the same-named Jpeg as a 'Raw+Jpg" 'pair', so won't show you the jpeg in the import screen. After import, check one of the Tiffs for which you have a matching Jpeg and you should see a jpg sidecar file listed in the metadata panel, and the file name in the Info Overlay will be filename.TIF + JPEG.

Try selecting the preference option and try the import again.
Photo of Dave Burbank

Dave Burbank

  • 4 Posts
  • 1 Reply Like
You guys are awesome. Once I checked the "Treat Raw and Jpeg as separate files" option in Prefs the images are now appearing in the import dialog. Thank you!
Photo of werew hretrwe

werew hretrwe

  • 1 Post
  • 0 Reply Likes
Hey guys, I had the same problem, which confused me a lot because I could clearly see some JPEG files with Explorer, but failed to find them in Lightroom.
As they were JPEGs, I thought that it has nothing to do with RAW-JPEG pairing.
But when I checked "Treat Raw and Jpeg as separate files" and saw those lost JPEG files, I realized what happened behind the hood:

say you have some photos in a folder, and there is DSC_0048.jpeg, but there is also DSC_0048.raw (which is absolutely another photo, just by accident having the same name), then Lightroom will pair them together by default and will prefer RAW over JPEG, so you won't be able to see your JPEG.