Lightroom 4.0 Bug? Plugin metadata - can't update catalog.

  • 1
  • Question
  • Updated 7 years ago
How to get rid of this error message, and update catalog, so I can use my plugin?



It happens when I try to enable the plugin, after affirming a catalog update.

Here is the offending line from the metadata provider module:

{ id='Clarity2012', title='Clarity 2012', version=2, dataType='string', readOnly=true, searchable=true, browsable=true },

Bumping version number did not help.

Note: The error occurs before updateFromEarlierSchemaVersion is called.

R
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 384 Reply Likes

Posted 7 years ago

  • 1
Photo of sizzlingbadger

sizzlingbadger

  • 31 Posts
  • 0 Reply Likes
Are you upgrading a LR3 or LR4b catalog ?

Is it one you have used your beta upgrade workaround on ?

Also, have you tried exporting the catalog first to see if that helps ?

May be useful for the developers to know...
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 384 Reply Likes
My upgrade did nothing you couldn't do yourself, it just automated it.

If this is a problem for me, it would also be a problem for anybody else who had done the same things by hand (e.g. created collections, stacked photos, made virtual copies...).

I will try exporting the catalog - thanks.

Assuming Adobe does NOT already have a clue about this, then I will try to get more info.

It's an Lr3 catalog with photos from Lr4b catalog imported into it.

?