Lightroom 3 presets in Lightroom 4

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
I noticed this today and perhaps it has been mentioned previously. When using the user presets from LR3 in LR4 the slider names revert to LR3 labels and settings and are not transfered to the new LR4 sliders.
Photo of Ed Devereaux

Ed Devereaux

  • 3 Posts
  • 0 Reply Likes
  • unconcerned

Posted 6 years ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 333 Reply Likes
A couple of factors are in play:

1. Is the Process Version accounted for (checked) in the Preset? You can test by checking the PV in the Camera Calibration panel, applying the preset and seeing if it changes.

2. Is the slider moved by the preset no longer available in the LR4 PV2012? (Brightness, Fill Light, Recovery, to name a few)?

LR4 will revert to PV2010 or even 2003 if the preset tells it to. In that case, the available sliders will revert as well.
Photo of Ed Devereaux

Ed Devereaux

  • 3 Posts
  • 0 Reply Likes
The presets change from shadows and the other new labels back to fill light etc.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
Exactly the point here Ed. If your Preset includes the Process Version, it will revert the sliders. To illustrate this point, go to an image you haven't applied a preset to (so you have the new sliders showing), go to the Camera Calibration roll-out and change the Process from 2012 (Current) to 2010. You will then notice that the Basic roll-out has changed it's sliders back.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes


Photo of Ed Devereaux

Ed Devereaux

  • 3 Posts
  • 0 Reply Likes
That is just a so simple fix that I am hitting myself not seeing that. That is pretty cool. I