Lightroom 3.5RC will not write Keywords to TIFF files

  • 1
  • Problem
  • Updated 7 years ago
Lightroom 3.5RC will not write keywords to TIFF files. This occurs with TIFFs that have been created in Lightroom and sent to Nik Silverefex 2 for editing. I have checked using Lightroom 3.4 which does not show this issues so it definately appears to have been introduce with 3.5RC.
Photo of Neil Cartwright

Neil Cartwright

  • 5 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of john beardsworth

john beardsworth

  • 1041 Posts
  • 239 Reply Likes
I don't think this is a Lightroom issue but is another symptom of how SFX2 screws up hierarchical keywords - see this thread and note later posts proving it's SFX2 and not LR that's the cause.

John
Photo of Neil Cartwright

Neil Cartwright

  • 5 Posts
  • 0 Reply Likes
I am aware of the SFX2 issue with keywords and this is not that issue. The TIFFs are exported to SFX2 from a virtual copy with the Keywords deleted. The kewords are then added to the TIFF by copying from the original DNG post editing in SFX2. This work around solves the keywording issue with Lightroom and SFX2. The problem occurs when trying to write the Keywords to the TIFF I.e. "Save Metadata to file".

I originally thought this was SFX2 so I tried it with Lightroom 3.4.1 and all is well with this version. The problem only occurs with 3.5RC which would suggest that it has been introduced by this version. It may very well be that it is an interaction between TIFFs edited by SFX2 and Lightroom 3.5RC but it is not the known issue and is not apprent with earlier versions of Lightroom.

Neil
Photo of john beardsworth

john beardsworth

  • 1041 Posts
  • 239 Reply Likes
OK, I can replicate this problem with 3.5RC. Win 7 64 bit. It doesn't just affect keywords, but LR fails to write labels, ratings or any other metadata.

An identical workflow through Photoshop doesn't cause the problem, so I do think it's another symptom of what SFX is doing to the files.

John
Photo of Neil Cartwright

Neil Cartwright

  • 5 Posts
  • 0 Reply Likes
I will have another look this weekend with SFX to see if it has the same issues as SFX2. It looks like this will be another one to report back to Nik as SFX2 is becoming increasingly unusable. I could live with the temporary workaround but there has been a significant time now with no fix and if this latest issue will preclude the use of SFX2 with future editions of Lightroom then for me and many others SFX2 will be completely useless!

Neil
Photo of john beardsworth

john beardsworth

  • 1041 Posts
  • 239 Reply Likes
Yes, I agree - it's looking more serious than before.

John
Photo of Neil Cartwright

Neil Cartwright

  • 5 Posts
  • 0 Reply Likes
All appears well when using SFX so I have put in a support request to NIK. It will be interesting to see when this issue gets fixed given the lack of progress to date. I will be sticking with SFX for now as SFX2 is completely unusable for me if future compatibility of TIFFs produced with Lightroom is in question!

Neil
Photo of Neil Cartwright

Neil Cartwright

  • 5 Posts
  • 0 Reply Likes
I have received a reply from Nik technical support. Apparently they are aware of the issue and will be providing an up "very soon".

Neil