Lightroom 3&4: Adjustment brush in erase mode: Keyboard shortcut for A/B-change does unexpected things

  • 1
  • Problem
  • Updated 12 months ago
  • Solved
Note: Not to be confused with!

Steps to reproduce:
1. Enter adjustment brush
2. Draw a brush stroke
3. Click on "A", set size, feather and flow of brush "A" all to 10, automask off
4. Click on "B", set size, feather and flow of brush "B" all to 20, automask on
5. Click on "Erase", set size, feather and flow of brush "A" all to 30, automask off
6. While in Erase mode, press the shortcut key for A/B-change (english: "/") twice.

Expected results - one of:
a) Nothing happens. There is no A/B in erase mode
b) Brush changes from erase mode to A, B, ... etc.

Actual result: Erase mode persists, but size, feather, flow and automask change to that of brush A, and on second key press to that of B, etc. The original settings for the erase brush are lost. If the settings are changed again, they are again lost when pressing the shortcut key (the original settings for A and B are not changed by that).

Tested in LR 3.6 and 4.1 RC 64 Bit, Windows 7, with german language and keyboard (shortcut "<") and english language and keyboard (shortcut "/").

P.S. Of course only a minor bug, but can be irritating ;-)
Photo of LRuserXY


  • 426 Posts
  • 41 Reply Likes

Posted 6 years ago

  • 1
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 38 Reply Likes
Yep, same here.
Photo of TK


  • 531 Posts
  • 108 Reply Likes
If someone fixes this, can they please also fix the Windows bug that prevents the keyboard shortcuts for the flow control of the temporary eraser brush from working?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13635 Posts
  • 1546 Reply Likes
This was fixed in Lightroom 5 and later.