Lightroom 3.4.1: Wrong tooltips for warning badge on thumbnails

  • 2
  • Problem
  • Updated 7 years ago
  • Solved
When LR detects that itself and an external application both changed the metadata, it displays a warning badge on the tumbnail. When clicked, a dialog to resolve the conflict appears.
=> Dialog uses resource MetadataUpdateConflictExplanation (OK).
=> Tooltip of badge uses resouce MetadataUpdateUnknownError ("error writing metadata"). This seems to be wrong.
=> I would have expected resource SidecarConflict ("Sidecar file has conflict") for tooltip.

Similar behaviour (warning badge, dialog when clicked) happens when an error occurs writing metadata to the file, but with other texts. In this case, I observed the following:
=> Dialog uses resource MetadataUpdateUnknownErrorExplanation (OK).
=> Tooltip of badge uses resouce SidecarConflict ("Sidecar file has conflict"). This seems to be wrong
=> I would have expected resource MetadataUpdateUnknownError ("error writing metadata") for tooltip.

It seems that LR sets the wrong tooltip in both cases, i.e. the resource references to both tooltips were accidentally swapped in lightrooms program code responsible for setting the warning badges.

Am I right or perhaps am I missing something?

Oh, and by the way: Strictly, the wording "Sidecar file has conflict" is not 100% correct because only proprietary RAWs have sidecar files. Perhaps "XMP data conflict" would be better?
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes
  • confused

Posted 8 years ago

  • 2
Photo of Geoff Walker

Geoff Walker, Champion

  • 223 Posts
  • 47 Reply Likes
I'll change this to an idea so others can vote on it. Personally I see your thinking on this.
Photo of Geoff Walker

Geoff Walker, Champion

  • 223 Posts
  • 47 Reply Likes
Rob good thing is you or I don't get the say on what is fixed and when, we just get the opportunity to vote for it here or not.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 387 Reply Likes
If I understand this 'Idea' (initially 'Problem Report') correctly, the tooltips are reversed and should be swapped. Can't this just be fixed sans risk in short order?

Doesn't seem to warrant a vote to me.
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes
I have to revive this nearly year-old thread. The wrong tooltips are somewhat annoying when working a lot with external metadata-changing applications such as geosetter or LRtimelapse.

The main point is that when the external application changes something, and afterwards something different is changed from inside LR for an image, the metadata status on the metadata pane correctly changes to "Conflict detected", but the tooltip on the badge incorrectly states "Error writing metadata".

On the other hand, if there *really* was a file write error on the XMP file when saving the metadata, the badge tooltip incorrecly states "Sidecar file has conflict", although "Error writing metadata" would be correct.

I checked again in LR 4.1 RC2, and the exact same bug is still there. The resources seem to be correct (I checked the de resources - the german tooltips are equivalent to the english ones, and are also equivalent to the meaning of the respective logical resource names). The bug must be that LR internally uses the wrong resources when setting the tooltip in these two situations: As mentioned in my original post, It incorrectly uses $$$/AgLibrary/WarningBadge/Tooltip/SidecarConflict when it should correctly use $$$/AgLibrary/WarningBadge/Tooltip/MetadataUpdateUnknownError and vice versa.

I still can't understand why my problem report was demoted to an idea although it was indirectly acknowledged as a problem if I understand it correctly (quote: "Personally I see your thinking on this."). Problems have a voting function, too, so that couldn't be the cause. To be honest, that left me somewhat frustrated back then, but I didn't say anything because the bug was just a curiosity for me rather a real problem. Now that I use external applications more often, it becomes relevant for me because with e.g. LRTimelapse you are at constant risk to make a wrong XMP read/save operation in both applications and a correct tooltip display is very important if a metadata conflict arises (for instance, if you are in develop most of the time where you don't see the metadata pane and have to rely on the tooltips in the film strip).

==> Adobe, please change this back to a problem, try to reproduce it and enter it into your bug database. The bug should be easy to locate and as Rob Cole already said should be fixable without any higher risk.
Photo of Chris Packrat

Chris Packrat

  • 30 Posts
  • 2 Reply Likes
OK, where and how should one vote to decide whether it's a bug or a feature?

Suggestion: let's do some lobbying in the outside world, protest in front of Adobe's offices worldwide, and get a thousand million votes on this funny forum, so that Adobe can rebadge the "idea" a "bug report", pass it on to some of their in-house rocket scientists, and have the whole problem gone in 60 seconds.
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 486 Posts
  • 77 Reply Likes
Sounds like a bug to me. I've entered it in our bug database.

Thanks,
Ben
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 486 Posts
  • 77 Reply Likes
Official Response
This has been fixed in 4.2.

Thanks,
Ben
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes
Great, thanks!