Lightroom Write changes to XMP seems to be sticky

  • 1
  • Question
  • Updated 1 year ago
  • Answered
I always convert to DNG on import.

I don't use the "auto write to xmp" because my whole DNG file is updated every edit, not just the little side-car.  That's bad new for performance and incremental backups as it now sees the file date changing every edit.  For that reason i don't have the tick box set.

All good.  Except, if I tick the box and edit a file (DNG is updated) then un-check the box and edit again, it seems to keep updating the DNG even though the tick box is un-ticked.  That is really bad news as it means if you accidentally used it once those files, they are trapped in this mode.

I came across this when I was working out how to convert a messy file system to a dated structure.  Obvious option was to write all edits to DNG's using the feature, delete all the files from catalogue, then re-import into nice structure with edits intact.  Unfortunately, once they have embedded edits, it seems they are stuck in this mode.
Photo of Adrian Beasley

Adrian Beasley

  • 43 Posts
  • 4 Reply Likes

Posted 1 year ago

  • 1
Photo of Tom Mickow

Tom Mickow

  • 288 Posts
  • 95 Reply Likes
I wasn't able to replicate that behavior on my Win10 & Lr CC 2015.10.1 setup.

With the box checked, I was able to make changes and verify that those were written to the dng automatically.  After unchecking the box, I made changes to the same image and verified that those were not automatically written to the dng.  Appears to be working as expected for me.

Did you happen to try closing and reopening Lr after making the setting change?

If that still doesn't do it, you may want to try resetting your preference file - https://helpx.adobe.com/lightroom/help/setting-preferences-lightroom.html

Btw, from the sound of what you're trying to do, a better way to get the changes written to your dngs might be to simply select all of them in the Library grid view and then choose "Save Metadata to File" from the Metadata menu or use the Ctrl (PC) / Command (Mac) + S keyboard shortcut.
Photo of Adrian Beasley

Adrian Beasley

  • 43 Posts
  • 4 Reply Likes
Ok, re-visited it and you are right, it is no longer sticky!  Thank you.

It was a problem but obviously now fixed.  However, I'm going to have to roll back an issue having just seen that the TAT tool is now broken :(