Lightroom: Won't stop to open when inserting memory card/device

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Even though i have un-ticked the box in settings, lightroom still opens whenever i connect a memory card, hard drive, camera, phone, watch, etc
Extremely annoying!

Im using Lightroom CC by subscription.
Photo of Joakim Olsson

Joakim Olsson

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3818 Posts
  • 1264 Reply Likes
Check your Windows autoplay options. Lightroom's not in control when it's closed, so it must be the OS opening it.
Photo of Dennis Durack

Dennis Durack

  • 10 Posts
  • 0 Reply Likes
I have the opposite problem, I have the box ticked but it will not open when I insert a card. Also the correct box ticked in Windows Auto Play.
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
Are you on Windows? Or Mac?
Photo of Dennis Durack

Dennis Durack

  • 10 Posts
  • 0 Reply Likes
I am on Windows 10
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
Very strange. Have you tried restarting Lightroom and or the system after ticking the correct settings?
Photo of Dennis Durack

Dennis Durack

  • 10 Posts
  • 0 Reply Likes
Yes many times, when I connect a tablet or phone it opens OK it is only a photo card that doesn't open.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
Could you post a screenshot of your autoplay dialog/settings and your Lightroom preferences for opening import? That may give some clues. Also, there are some subtle differences for SD cards if a built in slot is used or an external reader/device is used. What are you using to plug your SD card in?
Photo of Dennis Durack

Dennis Durack

  • 10 Posts
  • 0 Reply Likes
I have attached the screen grabs you requested. I am using a new computer that has a 17 in 1 built in card reader which seems to be the problem, when I use the external reader all is OK. This is the first time I have used the external reader with this computer.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3142 Posts
  • 504 Reply Likes
The top option: Removable Drive. If you set that to default to Lightroom, does that cure it for the internal card reader?
Photo of Dennis Durack

Dennis Durack

  • 10 Posts
  • 0 Reply Likes
The Removable Drive is already defaulted to Lightroom as can be seen by the tick box in the 'Choose what to do with each type of media'.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
If you uncheck "Choose what to do with each type of media" and select "Import Photos" ""Adobe Lightroom)" from the "Choose a default" pop-up above, does it work? I think that's what Rikk was suggesting.
(Edited)
Photo of Dennis Durack

Dennis Durack

  • 10 Posts
  • 0 Reply Likes
OK I have tried that and now I am suspecting a fault with the internal drive, I will contact the computer manufacturer

Thanks everyone for your help..