Lightroom Web: Capture time display bug

  • 1
  • Problem
  • Updated 2 days ago
  • (Edited)
I have found what appears to be a minor bug in Lightroom on the Web.

Scenario: Photos are imported into LR Classic, and Smart Previews subsequently synced to the cloud. View photos using LRWeb. Open the "Info" panel.

Problem: For some photos (not all), the capture time is displayed as a "PM" time when it should be an "AM" time. The time itself (HH:MM:SS) is correct, just the "PM" part is wrong. The capture time is shown correctly in LR Classic, and in LR for Android. Only LR Web has a problem.

Further review seems to indicate that only photos taken in the hour between 11:00am and 12:00pm are affected. In other words, a photo taken at 10:59am will display correctly, but a photo taken at 11:01am will display as 11:01pm.
Photo of prbimages

prbimages

  • 9 Posts
  • 1 Reply Like

Posted 2 weeks ago

  • 1
Photo of Just Shot Me

Just Shot Me

  • 211 Posts
  • 54 Reply Likes
I'm seeing something similar. In fact the date/time on LR web is screwy. Some images have the same date/time for both Capture Time and Uploaded Time, capture time being right, which is totally wrong. I also see images take on the same day, in the AM, listed as PM. I'm thinking it is a Time Difference from where I am, east coast, and where the servers are, more than likely west coast. Images shot around 9 AM show AM and images shot around 11 AM show as PM.
Photo of Alex Dixon

Alex Dixon, Company Admin

  • 45 Posts
  • 17 Reply Likes
Thanks for giving us a heads up. It'd be helpful to know which browser you're seeing this on, and if possible if you're seeing the same behavior on a couple of browsers. Definitely looks like something we want to fix -- very strange.
Photo of Alex Dixon

Alex Dixon, Company Admin

  • 45 Posts
  • 17 Reply Likes
Actually we've got a fix in progress. We just have a simple logic bug where we display `pm` by mistake for times from 11am-noon. We've had some weirder display bugs here in the past that got me paranoid...
Photo of prbimages

prbimages

  • 9 Posts
  • 1 Reply Like
Thanks Alex, I will look forward to the fix!

Just for the record, I was using Google Chrome. I just tried Opera, and I see that it displays the capture time in 24-hour format without any AM/PM suffix, and the time is correct. Kind of interesting that it doesn't use the same format.

Thanks again, prbimages :)
Photo of Alex Dixon

Alex Dixon, Company Admin

  • 45 Posts
  • 17 Reply Likes
Just wanted to shoot another update, mostly since there's some subtleties in the display that might be useful to other folks that see this thread in the future.
  1. The "capture date" is usually written by the camera, and doesn't always include a timezone. When we display this, we always just show the time as captured, and don't do any timezone conversion. So if you took a photo overseas at 3pm there, that's what we'll show.
  2. The "upload/import" time is written by us at the start of an upload/import. We always write this in UTC, and it's the same for all photos in an import batch. When we display this we always convert to the current local time. I should also mention that we've fixed a few issues with writing this field in the past few years, so you might see slightly different behavior for older photos.
  3. We change our date display based on the language selected. If you were seeing a 24-hour format in Opera, I'm wondering if the language we're selecting is en-GB rather than en-US (possibly because Opera has a different default). The actual bug we had just affected 12-hour time formats.

Cheers,
Alex
(Edited)
Photo of Just Shot Me

Just Shot Me

  • 210 Posts
  • 54 Reply Likes
Still screwy. Capture time looks to be OK but the Upload times some times mimic the capture time.
Isn't Uploaded time supposed to be when it was Synced with LR web/mobile.

Photo of Alex Dixon

Alex Dixon, Company Admin

  • 45 Posts
  • 17 Reply Likes
If the capture date & upload times are matching, that might be an import bug in one of our clients. Do you know which application you used to import that photo? And are you seeing a bunch of photos in that state?
(Edited)
Photo of Just Shot Me

Just Shot Me

  • 210 Posts
  • 54 Reply Likes
All my images are imported into LR With LR. From memory card in card reader to computer hard drive and into the LR Classic CC catalog. Then if I add any to an existing synced collection or create a new collection that I will sync with LR Web/Mobile that happens some time, hours or days later.
Actually all images I have synced and view on the LR web page/interface show the Upload Time the same as the Capture Time. None of my images are Auto Added to LR at the time of capture. LR is home on my computer and my camera is with me recording images to the memory card in the memory card slot in the camera. It may be several hours to days before they get copied over from memory card to computer hard drive and imported into the LR C CC catalog. Then hours or days if I chose to sync any with LR Web/Mobile.
I don't take picture with my phone and never use the camera feature in LR mobile that I have installed on my phone.
Photo of Alex Dixon

Alex Dixon, Company Admin

  • 45 Posts
  • 17 Reply Likes
@Just Shot Me -- I've reported this to the LR Classic team, as the behavior you've described sounds like a bug in the import/sync logic there.
Photo of Alex Dixon

Alex Dixon, Company Admin

  • 45 Posts
  • 17 Reply Likes
@Just Shot Me if you're seeing this behavior in images added to the latest version of Lr Classic CC, please let us know and we'll investigate further.

Lr Classic will populate the import time with the time it was imported into Classic, not the time it was first synced with the cloud. It sounds like it uses the capture date if that's not available though, which explains the behavior you're seeing.

The team wasn't able to reproduce the capture date behavior with the latest version of Lr Classic. If they can find a bug that was fixed related to this they'll update here.

Cheers,
Alex
(Edited)
Photo of Marc Schmid

Marc Schmid

  • 4 Posts
  • 1 Reply Like
Hi there, I just signed up for a lightroom cc account in order to have all my pictures there as I read a lot about how easy it would be to manage photos conveniently including cloud and mobile editing.
Now, I had all my pics in order by the time they were taken, my "camera roll" from over the years, now c. 15,000. My idea was to sort through them with Lightroom CC only to find that now it is a big mess and mostly the capture date displays the date it was imported or changed. Can you please re-confirm you are working on a solution to this for Lightroom CC? Thank you
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3818 Posts
  • 718 Reply Likes
Not related to parent topic - starting new thread

Please reference the new conversation here: Lightroom CC: Capture Date Shows Imported or Changed instead of Capture Date