Lightroom Using Excessively High Resources with Most Recent Update

  • 4
  • Problem
  • Updated 11 months ago
This morning I updated both my home and work computers to the newest version of Adobe Lightroom. Upon restarting, Lightroom is using an absurd amount of RAM and CPU resources when performing basically any task, but most prominently when exporting and syncing develop settings (see screenshot below):



This has only occured since the new update. I have been using Lightroom all weekend before updating with absolutely no issue (other than the typical preview rendering and preset application lags).

Is anyone else experiencing this, and can somebody please tell me if there is a fix I don't know about?

My home machine specs are as follows:



My work machine specs are as follows:

Photo of Creative Catalyst

Creative Catalyst

  • 91 Posts
  • 30 Reply Likes
  • frustrated

Posted 2 years ago

  • 4
Photo of David Fabian

David Fabian

  • 77 Posts
  • 18 Reply Likes
Keep LR running for a couple of hours doing nothing at all and see if you get the memory leak problem. Fire off a couple of modules and just watch the memory consumption. It's getting to be that the requirements should be Max Ram, SSD and tested and approved GPU video card , and no more than 2 monitors on your entire system.
I like LR, but it's also good to know the limitations of the system. So I only turn it on when I need something.
Photo of Creative Catalyst

Creative Catalyst

  • 91 Posts
  • 30 Reply Likes
I've been using Capture One Pro 10 a lot more lately precisely because Lightroom is such a memory hog. I would like to stick with Adobe on this, but it's hard to justify when C1 Pro is much lighter and has more features.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4291 Posts
  • 819 Reply Likes
Normally this means you that you need to uninstall Lightroom, reboot and reinstall Lightroom from a fresh update.
Photo of raden adams

raden adams

  • 3 Posts
  • 0 Reply Likes
Yes, heck yes. my memory and c disk is running over 100% all the time. So, is this really what I need to do to correct this?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4291 Posts
  • 819 Reply Likes
A bad install can cause the issues you are seeing. GIven that (depending upon your download speed) it takes about 10 minutes, it is a reasonable troubleshooting step to take.
Photo of Creative Catalyst

Creative Catalyst

  • 91 Posts
  • 30 Reply Likes
This reply was created from a merged topic originally titled Light Room Using an Obscene Amount of Resources.

Lightroom is using an excessively large amount of CPU and RAM resources since this latest update. How come it seems this happens every other update to LR? Any thoughts from Adobe??? This is so annoying. I can't even work with it. It just lags and jumps, images take forever to render, exporting is painful. It's ridiculous. This needs to be fixed!!!

Specs:
Windows 10 Enterprise
Intel Core i7 3.4GHz CPU
Nvidia GeForce GTX 1070 GPU
32GB DDR3 RAM
SSD Hard Drive



Nothing else has changed on my system. This started happening as soon as I updated to the most recent LR version through the CC app. Currently 2015.9 Release Camera Raw 9.9. 
Photo of Steve Gandy

Steve Gandy

  • 109 Posts
  • 36 Reply Likes
I routinely turn off face recognition and address lookup and I never seem to have these slow down problems. I don't never really use either of those functions. I keep hearing about these slow down issues but never really see it myself.
Photo of Ruby Maurya

Ruby Maurya

  • 11 Posts
  • 0 Reply Likes
Can you please following info regarding same problem
1) Number of export batches you have run
2) Number of photos in each batch
3) Is there any other operation running in parallel while performing sync and export?
4)CPU and RAM consumption continues even after sync and export finishes? if yes , how long?
Photo of WxGuesser

WxGuesser

  • 2 Posts
  • 0 Reply Likes
I discovered that it only happens when lightroomhas been syncing for at least ten minutes. I have turned off sync completly.