Lightroom: Mobile syncing stuck

  • 4
  • Problem
  • Updated 2 years ago
  • (Edited)
My Lightroom stops syncing with lightroom mobile. It shows the numbers of photos left to sync but nothing happens for ages. I already tried to erase everything and start over many times. Sometimes it works fine for a few days or weeks but eventually it gets stuck again. I'm fed up and paying too much for it. When it works it's wonderful.
Photo of Hideki Perrier

Hideki Perrier

  • 1 Post
  • 0 Reply Likes
  • fed up and frustrated

Posted 4 years ago

  • 4
Photo of Guido Reule

Guido Reule, Employee

  • 72 Posts
  • 14 Reply Likes
are you on LrD version 5.6. If so, could you try to remove the sync.lrdata file and restart LrD.

This would restart/refresh the sync (metadata only).
Removing the Sync.lrdata might fix whatever the issue is. Or, at least, might trigger it to occur again. So remove the Sync.lrdata, start Lr, and then wait until it either syncs or gets stuck again and create at this point a Lr desktop diagnostic log which can hopefully provide some clues.

You can find the sync.lrdata file here:
On Mac it's at /Users//Library/Caches/Adobe/Lightroom/Sync Data/Sync.lrdata
On Win it would be at C:\Users\\AppData\Local\Adobe\Lightroom\Caches\Sync Data\Sync.lrdata

Please send me a LR Desktop diagnostig log - best as a private message with a downloadable dropbox link.

You can trigger the log via LR Desktop preferences -> Lightroom Mobile and when you hold down the alt key you will notice a generate diagnostic log button

-
Guido
Photo of Eric Gingras

Eric Gingras

  • 4 Posts
  • 2 Reply Likes
For what it's worth, I had the same problem with it getting stuck. This occurred after I moved some images on my iPhone into a new collection. Deleting the Sync.lrdata file seems to have fixed the issue.
Photo of David Erlmeier

David Erlmeier

  • 1 Post
  • 1 Reply Like
I can confirm that this issue occurs, as Eric Gingras described, when creating a new collection on iOS. I imported some pictures I shot with my iPhone. Shortly I noticed that 7353 Pictures wanted to resync but won't make progess. Removing Sync.lrdata solves the problem.
Photo of Bill Fuller

Bill Fuller

  • 1 Post
  • 0 Reply Likes
I've got the same issue but I'm unable to find the sync.lrdata file. I'm using release 2015.4. 
Photo of Drew MacAlmon

Drew MacAlmon

  • 1 Post
  • 0 Reply Likes
Worked for me as well. Thanks.
Photo of rcostain

rcostain

  • 2 Posts
  • 2 Reply Likes
I'd like to figure out which of the 8 photos that LR hasn't been able to sync are causing the issue. I deleted the Sync.lrdata file and it got me nowhere.
Photo of rcostain

rcostain

  • 2 Posts
  • 2 Reply Likes
If I could actually determine which images aren't syncing, I would remove them from the Library and be done with it. I suspect they may be screen caps in a non-standard format, but there's no way to tell, and no indication in the UI that indicates which collection the offending images are in.
Consider it a feature request that users should be able to see a list of pending images in the sync queue.
Photo of Edmund Butler

Edmund Butler

  • 1 Post
  • 0 Reply Likes
I could not find the lr data file mentioned. My issue seems to be that LrM images are no longer syncing to LrD over Wifi as they once were. On LrM I have Sync only over Wifi 'On'. In LrD, Sync with LrM seems to be turning off without quitting the programme, and also whenever I quit the programme. I have created a Collection on LrM and still no images on LrM. What, oh what can I be missing? ;