Lightroom: Still inconsistent capture date/time for photos and videos

  • 39
  • Problem
  • Updated 5 days ago
  • (Edited)
Update 8/21/2017: LR has two closely related problems with a single underlying cause:

- With photos and videos missing metadata capture date/times, LR shows inconsistent capture times under the Library thumbnails, in the Metadata panel, and in the Library Filter bar.  Sorting, filtering, and searching with smart collections work inconsistently, using different values for the files' capture times.

- Changing IPTC Date Created in the Metadata panel, either by editing the field or using Metadata > Copy/Paste Metadata, similarly causes inconsistent values to be shown and sorting and searching to work inconsistently.  It also causes date metadata to be written back to the files that doesn't conform with the Metadata Working Group's standard.

The underlying cause is architectural: LR doesn't have a single internal catalog field representing "capture time".  Rather, it maintains capture time in several different fields, and the various parts of LR update those fields inconsistently.

See here for precise recipes to replicate these bugs:

https://feedback.photoshop.com/photoshop_family/topics/lightroom-still-inconsistent-capture-date-tim...

https://feedback.photoshop.com/photoshop_family/topics/lightroom-still-inconsistent-capture-date-tim...

See here for a workaround: 

https://feedback.photoshop.com/photoshop_family/topics/lightroom-still-inconsistent-capture-date-time-for-videos?topic-reply-list%5Bsettings%5D%5Bfilter_by%5D=all&topic-reply-list%5Bsettings%5D%5Breply_id%5D=15475521#reply_15475521.  

-------------

LR 5.7 still shows inconsistent capture date/times for videos. For a test .avi on Windows 8.1, the date in grid view appears to be the file system's last-modified time, while Capture Date/Time is set to the time of import.This problem was declared fixed in LR 5.5, and it appears to have been fixed for images, but not videos:http://feedback.photoshop.com/photoshop_family/topics/inconsistent_dates_for_files_missing_date_time...I'm opening a new topic, since the previous one has been marked "Solved".
Photo of John R. Ellis

John R. Ellis, Champion

  • 3125 Posts
  • 741 Reply Likes

Posted 3 years ago

  • 39
Photo of Melissa Rios

Melissa Rios, Lightroom Support Product Manager

  • 87 Posts
  • 20 Reply Likes
Official Response
Hi all,

Just to reiterate what Sunil said in a comment above, this issue should be fixed in Lightroom Classic CC 7.1. Please let us know if you're still seeing this issue after updating.

Thanks,
Melissa