Lightroom: Silently installed Logitech plugin causes problems for many people

  • 2
  • Problem
  • Updated 4 days ago
  • Solved
  • (Edited)
The Logi Options utility that comes with Logitech keyboards and mice silently installs a plugin LogiOptionLr that continues to cause significant problems for many people, most of whom don't even know that a LR plugin was installed. Perhaps a senior Adobe product manager could have a "conversation" with a counterpart at Logitech, since they've given no indication on the Logitech forums of being responsive to mere customers over the past year.

Two different problems have been reported:

- LR can take 2 minutes or more to start up, and sometimes it hangs.

- Deleting a photo from the catalog can result in "Aninternal error has occurred: ?:0: attempt to index a nil value"

Forum posts about very slow startups and hangs:
https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-slow-to-start
https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-8-4-hanging
https://community.adobe.com/t5/lightroom-classic/lrc-slow-startup-or-not-reponding-at-all/m-p/112836...
https://community.adobe.com/t5/lightroom-classic/anyone-having-trouble-with-lr-classic-loading/m-p/1...
https://community.adobe.com/t5/lightroom-classic/slow-initial-load-in-lightroom-classic/m-p/11230296...
https://community.adobe.com/t5/lightroom-classic/lightroom-not-responding-issue/m-p/11170853?page=1#...
https://community.adobe.com/t5/lightroom-classic/lr-classic-9-1-error-quot-an-internal-error-has-occ...
https://community.adobe.com/t5/lightroom-classic/lightroom-classic-slow-to-launch-on-windows-10-actu...
https://community.adobe.com/t5/lightroom-classic/lightroom-classic-new-installs-hang-after-startup/m...
https://community.adobe.com/t5/lightroom-classic/lightroom-9-1-slow-start/td-p/10829531/page/2?page=...
https://community.adobe.com/t5/lightroom-classic/lightroom-classic-9-2-crashes-when-quot-delete-reje...
https://community.adobe.com/t5/lightroom-classic/double-loading-of-splash-screen/m-p/10895216?page=2...
https://community.adobe.com/t5/lightroom-classic/whenever-i-open-lightroom-cc-in-windows-10-it-stops...
https://community.adobe.com/t5/lightroom-classic/lightroom-classic-version-9-1-on-windows-10-home-no...
https://community.adobe.com/t5/lightroom-classic/lightroom-9-agonizingly-slow-to-launch-and-become-r...
https://community.adobe.com/t5/lightroom-classic/how-to-improve-the-startup/m-p/10619767?page=1#M156...
https://community.adobe.com/t5/lightroom-classic/lightroom-classic-cc-stuck-on-quot-reading-preferen...
https://community.adobe.com/t5/lightroom-classic/lightroom-takes-too-long-to-load-when-onedrive-app-...
https://community.adobe.com/t5/lightroom-classic/is-it-just-me-or-is-lr-8-3-much-slower/m-p/10543617...
https://www.lightroomqueen.com/community/threads/lr-8-4-slow-startup.38324/#post-1254162

Forum posts about "internal error" when deleting photos:
https://community.adobe.com/t5/lightroom-classic/error-message-every-time-i-remove-a-photo-from-any-...
https://community.adobe.com/t5/lightroom-classic/lightroom-classic-9-2-crashes-when-quot-delete-reje...
https://community.adobe.com/t5/lightroom-classic/lightroom-cc-an-internal-error-has-occurred-0-attem...
https://community.adobe.com/t5/lightroom-classic/after-deleting-a-photo-the-program-does-not-respond...
https://community.adobe.com/t5/lightroom-classic/frequent-error-when-removing-photos-from-catalog/m-...
https://community.adobe.com/t5/lightroom-classic/ein-interner-fehler-ist-aufgetreten-0-attempt-to-in...
https://feedback.photoshop.com/photoshop_family/topics/-an-internal-error-has-occurred-0-attempt-to-...
https://www.lightroomqueen.com/community/threads/deleting-a-photo-works-for-1-but-then-goes-into-a-l...

Posts in the Logitech forums:
https://support.logi.com/hc/en-us/community/posts/360048400514-LogiOptions-is-causing-extremely-slow...
https://support.logi.com/hc/en-us/community/posts/360046711494-LogiOptions-Plugin-and-Lightroom-Clas...
https://support.logi.com/hc/en-us/community/posts/360032900233-Logitech-Craft-Options-not-detecting-...
https://support.logi.com/hc/en-us/community/posts/360032843333-Craft-Keyboard-Lightroom-Classic-CC-P...
Photo of John R. Ellis

John R. Ellis, Champion

  • 5176 Posts
  • 1478 Reply Likes

Posted 4 weeks ago

  • 2
Photo of Bill

Bill

  • 292 Posts
  • 53 Reply Likes
While a fan of Logitech products for years, I finally gave up on them for Windows. Just too many compatibility issues. When it comes to a keyboard and mouse I've come to the conclusion that nothing works as well as the wired Microsoft products.
Photo of Dan Hartford Photo

Dan Hartford Photo

  • 470 Posts
  • 221 Reply Likes
John,

I don't have Logitech so don't have this problem, but in case some of my clients do, does the stealth plugin show up in the LrC plugin manager and if so, is the remedy to disable/delete it?

thanks -- Dan
Photo of John R. Ellis

John R. Ellis, Champion

  • 5176 Posts
  • 1478 Reply Likes
It shows up in File > Plug-in Manager and simply disabling it has fixed the reported problems.

Removing it is a little more tedious -- it gets installed in the Modules subfolder of LR's settings folder, and as such, you can't use the Plug-in Manager's Remove command. But in the plugin's Status panel in the Plug-in Manager, you can click Show In Finder / Explorer and then delete the folder LogiOptionLr.lrplugin.
Photo of John R. Ellis

John R. Ellis, Champion

  • 5176 Posts
  • 1478 Reply Likes
I wouldn't say this problem is "solved", since Logitech is still silently installing the plugin and screwing users.  Latest report:

https://community.adobe.com/t5/lightroom-classic/lightroom-classic-not-responding/m-p/11336589#M1962...