Lightroom shows older ghost picture with some newly imported pictures...

  • 1
  • Problem
  • Updated 1 month ago
Hi,
I have a problem that is affecting more and more of my pictures. When importing with Lightroom on osx 10.13 DNG pictures (32/64gb sandisk extremely pro) from my camera (Leica M monochrom typ246) some of them are shown as if they were older pictures. The older picture appears instead of the correct one in the thumbnail and at first when opening the picture but then turns back to be the actual picture it is supposed to be. It's quite annoying and I haven't been able to appreciate if this behaviour is damaging to the picture yet. Is this a known bug ? Does adobe know about it ? How can I report it as communicating with them is quite a challenge?...Is there a fix (yes I have reformat my cards several times) ? 
Thank you for your help!
Photo of VANIA PLEMIANNIKOV

VANIA PLEMIANNIKOV

  • 1 Post
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1680 Posts
  • 680 Reply Likes
Sounds like Lightroom is showing a cached preview of an older image, possibly with the same file name. If it shows the correct image after a short while, then this is just a visual glitch. It will not damage your images in any way. Maybe there is some corruption in your previews cache.

You may be able to solve this in the following way. Open your catalog folder and look for ‘catalogname previews.lrdata’. Trash it or move it out of that folder. Then start Lightroom again. Initially you will not see any previews, but Lightroom willl start rebuilding them so they should appear one by one. Now check that the odd behavior is gone when you import some images.