Lightroom Classic: Sets color labels with incorrect case in the label name, affecting filters

  • 2
  • Problem
  • Updated 3 weeks ago
  • Acknowledged
  • (Edited)
At some point, Lightroom set the blue color label on my photos to "blue" instead of the standard "Blue". This results in the toolbar filters & smart collection by color label not picking up these values. The only way to find the photos is to use the Attributes filter at the top of the grid, which will display the text values of the color labels, both "blue" and "Blue". At this point, the color labels of the incorrectly marked photos can be updated to the correct labels (via keyboard shortcuts or menu option). Going forward, all the photos will then be able to be found via all the filter options.

I've reported this as a Lightroom bug, but it might help someone so I'm reposting this problem & solution here.
See below the screenshots, illustrating the issue

- Notice the two highlighted blue photos

- Notice the filter results, filtering for blue photos, do not include these two photos

- Notice the attribute value of "Blue" in the filter list for the photos, matching the Blue color label filters, with the upper case B

- Without the color label filter applied, notice all the color label options available in the Attributes filter, specifically the "Blue" & "blue", with both the upper & lower case blue

- Applying the Attribute filter of "blue" with the lower case b results in the 2 original (and others) photos being shown.
At this point, selecting all photos and applying the desired color label (keyboard shortcut "9" or menu option) will mark all the photos as "Blue" and all the photos will be able to be retrieved with the standard filters
Photo of svetlana.day

svetlana.day

  • 26 Posts
  • 0 Reply Likes

Posted 4 weeks ago

  • 2
Photo of Chinoy Gupta

Chinoy Gupta, Employee

  • 49 Posts
  • 18 Reply Likes
Official Response
Hi All,

I agree with consistency issues. We will investigate it further.

Thanks,
Chinoy