Lightroom: Secondary monitor zoom in locks after using brush

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Windows 10, Lightroom 6.5.1.

Using dual monitor, in Develop on monitor 1 and loupe (normal) on monitor 2.

When using brush to modify an image (display 1) then using left click on display 2 to zoom in from "Fit" to "1:1", then click again to go back to "Fit", the latter does not work and the zoom stays in at 1:1.

Same problem with or without GPU accelaration. Happens 80% of the time. Zoom in/out works fine from monitor 1.

The only ways to come back (bypass) I have found are:

1) Go back to library (G or E) then come back to develop (D) and try again
2) Set the previous modification in develop history (remove the brush) and try again
3) Use the bottom command bar and click "Fit".

Only bypass 1 is "permanent" i.e you can then zoom in and out on display 2, and adding more brushes works fine.

It looks like it's only when creating the first brush, or setting in Develop History the last step before the first brush, then setting the remaining steps (or the first brush only) that creates the problem. Then, the zooming in is much longer than normal, and the zooming out fails. 

Anyone encountered the problem? Any fix for that?   
Photo of Claude PERRIN

Claude PERRIN

  • 4 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3170 Posts
  • 516 Reply Likes
Greetings Claude,

I attempted to duplicate what you are seeing using your instructions. I was unable to experience the lockup you are seeing on a Win 10 System with a dual monitor configuration. 

Recommendations:

1. Make sure your mouse/tablet drivers are up-to-date.
2. Make sure your video driver is the latest version from the video card manufacturer's website.  Don't rely on Windows update. 
3. Reset your Lightroom preferences file by closing Lightroom, holding down [Alt]+[Shift] and relaunching Lightroom. Overwrite the preferences when prompted. 

If these three items don't, singly or in concert, affect the problem you are seeing, we will need to get more specific system information to see if we can find a use case we can duplicate on our end. 
Photo of Claude PERRIN

Claude PERRIN

  • 4 Posts
  • 0 Reply Likes
Greetings Rikk

Long Bank holiday, this week-end, sorry for the delay replying.

Should have thought of the good old days resetting the preference file! Anyway, did it, but no go.

Thought all my drivers were up to date, but found that AMD have released for my graphics card a new version mid December last year, only six weeks after the one I had installed in November 2015, dated the same! Installed the new one, but still no go.

As far as my drivers for either a Wacom tablet, a Logitech trackball or a simplissime Microsoft mouse, they are all up to date, and have the same problem.

Analyzed a bit more the symptoms this morning, and it looks like when in "problem state", clicking on the secondary monitor puts it in "move image around" mode (Hand closed pointer) but never in "zoom back" mode (magnifying glass with + pointer).

Also, if it helps, when the problem arises, sometimes the primary monitor looses its image (Grey screen, but lateral and bottom strips remain) or even replaces the image by the vignettes from the library mode (?). This is no big deal, since it comes back to normal by simply moving the cursor back to the primary monitor.

I am dead certain this never happened in version 5. I installed LR6 a year ago, but didn't use it as extensively as from last march, so cannot say wether the problem existed since 6.0 or not.

The only modifications made are those of Windows 10, as they turn up, last update on.

I'll send whatever system information you need, here's a copy of the supplied Lightroom, and thank you for your help.

Lightroom version: 6.5.1 [ 1073342 ]
License: Perpetual
Operating system: Windows 10
Version: 10.0
Application architecture: x64
System architecture: x64
Logical processor count: 12
Processor speed: 3,2 GHz
Built-in memory: 65508,7 MB
Real memory available to Lightroom: 65508,7 MB
Real memory used by Lightroom: 2346,8 MB (3,5%)
Virtual memory used by Lightroom: 2696,3 MB
Memory cache size: 764,7 MB
Maximum thread count used by Camera Raw: 12
Camera Raw SIMD optimization: SSE2,AVX
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1200, 2) 1920x1200
Input types: Multitouch: No, Integrated touch: No, Integrated pen: Yes, External touch: No, External pen: Yes, Keyboard: No

Graphics Processor Info:
ATI FirePro V4800 (FireGL) Graphics Adapter

Check OpenGL support: Passed
Vendor: ATI Technologies Inc.
Version: 3.3.13411 Core Profile Context FireGL 15.201.2401.0
Renderer: ATI FirePro V4800 (FireGL) Graphics Adapter
LanguageVersion: 4.40


Application folder: C:\Program Files\Adobe\Adobe Lightroom
Library Path: D:\Mes images\Lightroom\Lightroom 6 D Catalog.lrcat
Settings Folder: C:\Users\GL\AppData\Roaming\Adobe\Lightroom

Installed Plugins:
1) Canon Tether Plugin
2) Facebook
3) Flickr
4) Leica Tether Plugin
5) Nikon Tether Plugin
6) Show Focus Points

Config.lua flags: None

Adapter #1: Vendor : 1002
    Device : 68c8
    Subsystem : 240a1002
    Revision : 0
    Video Memory : 1010
Adapter #2: Vendor : 1414
    Device : 8c
    Subsystem : 0
    Revision : 0
    Video Memory : 0
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Haut-parleurs (Realtek High Definition Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x102
Direct2DEnabled: false
GPUDevice: not available
OGLEnabled: true
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3157 Posts
  • 515 Reply Likes
A long shot here but if you disable your Show Focus Points plugin does it still misbehave? 

Our systems are very similar (I have nVidia) except I do not use the Focus Points plugin. 
Photo of Claude PERRIN

Claude PERRIN

  • 4 Posts
  • 0 Reply Likes
Thanks for trying hard, Rikk !

Disabled Focus point plug-in, re-launched LR, still no go.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3157 Posts
  • 515 Reply Likes
Thanks for trying. Now, if you switch the monitors so that Primary and Secondary are swapped?
Photo of Claude PERRIN

Claude PERRIN

  • 4 Posts
  • 0 Reply Likes
Graphics card gets 2XDisplay ports and 1xDVI.

Monitors are Dell 2408 and Asus PA246.

Dell is on DVI, Asus on Display port. When I bought the Dell, it was supposed to work on display port, but actually did not when I eventually built my own PC and chose my own graphics card. Thus, it prevents me from physically swapping ports.

Asus is on graphics card first (display) port, but defined to Windows as 2nd monitor, since I prefer to keep Dell (third DVI card port) as my "vignette" monitor, and Asus as my "good" monitor, though after calibrating, I find difficult to distinguish between the two!

Anyway, I asked Windows to swap (software then) primary and secondary monitor, and could recreate the problem on the Dell, just like on the Asus.

Thanks again for your help