Lightroom: Publishing service to Facebook page not working

  • 4
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Why it is not possible to publish photos through Lightroom publishing service to Facebook Page anymore. Under the publish service setup there is no more option to choose Facebook Page albums or timeline album. Only my personal Facebook page albums are available.
Photo of Mario Mesi

Mario Mesi

  • 14 Posts
  • 1 Reply Like

Posted 4 years ago

  • 4
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
I'm having this same problem! I am hoping to hear a reply from Adobe.
Photo of Michele Marie Randolph Tiny

Michele Marie Randolph Tiny

  • 8 Posts
  • 0 Reply Likes
I am having that problem but with LR 2015 CC
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
This reply was created from a merged topic originally titled Unable to publish photos to Facebook Pages!.

I have been posting photos to my Facebook Page "Paul Diming Photography" for a few years now. In the last two days I have not been able to post. When I try to create a new published Collection, I no longer see the existing Facebook Albums associated with my Facebook Page.

Please help!
Photo of Michele Marie Randolph Tiny

Michele Marie Randolph Tiny

  • 8 Posts
  • 0 Reply Likes
Same here, and I just now added FB publishing to my LR 2015 CC; it worked at first then my albums disappeared
Photo of James

James

  • 7 Posts
  • 2 Reply Likes
My Lightroom can post to my main facebook account, but suddenly can no longer post to the page I created for my photography.
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
Right on the money James. You are experiencing the same problem several of us are. Thank you for adding your voice!
Photo of James

James

  • 7 Posts
  • 2 Reply Likes
I'm sure it's facebook.
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
I've reported the problem to Facebook. Maybe it would help if everyone else did the same.
1. Click on the pull down on the far upper right of the screen.
2. Click "Report a Problem"
3. Click "Something Isn't Working"
4. Select Pages on the pull down.
5. Explain the problem.
6. Upload a screen image. I captured an image of trying to create a new published collection with the pull down showing no Page Albums listed.

It might help for Facebook to know that it isn't just me having the problem.

Paul.
Photo of Michele Marie Randolph Tiny

Michele Marie Randolph Tiny

  • 8 Posts
  • 0 Reply Likes
I reported the problem about an hour ago to FB but about my LR 2015 CC
Photo of James

James

  • 7 Posts
  • 2 Reply Likes
I reported it to facebook, as well. Can't hurt.
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
Excellent! Thanks James!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15248 Posts
  • 2194 Reply Likes
We're looking into it with our friends at Facebook.
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
Thank you Jeffery for yours and everyone's efforts at Adobe & Facebook who worked to solve this issue!

Job well done!

Paul.
Photo of Mario Mesi

Mario Mesi

  • 14 Posts
  • 1 Reply Like
Thank You very much Jeffrey! It's working now.
Photo of Michele Marie Randolph Tiny

Michele Marie Randolph Tiny

  • 8 Posts
  • 0 Reply Likes
How?  I just installed FB publishing to my LR 2015 CC, and I am having the exact problem today.  Everything worked fine until 15 minutes after I set up FB Publishing.  Can you help me - Jeffrey?
(Edited)
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
Thank you Jeffrey for your efforts to help us!

Let us know if you need any further information.

Paul.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 386 Reply Likes
Y'all might try Jeffrey Friedl's Facebook plugin until Adobe gets theirs straightened out..
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
Yes, I am using his plug-in until Adobe's publish service is working again. I just end up with more publish collections to manage than I would like. I publish to several albums on my FB page daily.
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
It looks like the problem has been resolved!

I am now able to select an Existing Non-User Album!

See if it works for you!

Awesome news!

Paul.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 386 Reply Likes
How was the issue resolved - any idea?
Photo of Paul Diming

Paul Diming

  • 11 Posts
  • 5 Reply Likes
That would be a question for Jeffrey Tranberry above. We tried our best to make the issue visible to Adobe and Facebook separately via bug reporting and forum input.
Photo of Mario Mesi

Mario Mesi

  • 14 Posts
  • 1 Reply Like
It's working now! Thanks to Jeffrey. Well done!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15248 Posts
  • 2194 Reply Likes
Cool. Glad to hear it's working now.
Photo of Mario Mesi

Mario Mesi

  • 14 Posts
  • 1 Reply Like
Yes really cool! Thanks for the quick reaction and solution!
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 386 Reply Likes
I'm still curious who changed what, or should I just chalk this up to "a miracle..".
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15248 Posts
  • 2194 Reply Likes
FB was able to flip some bits back.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 386 Reply Likes
Thanks Jeffrey.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15248 Posts
  • 2194 Reply Likes
Official Response
We've made FB posting more robust in Lightroom CC/Lightroom 6.
Photo of Amanda Hutchings

Amanda Hutchings

  • 1 Post
  • 0 Reply Likes
Hi Jeffrey! I have LR6 and for some reason I can't get my business facebook page to authorize. It doesn't tell me that it can't be done but when I click Authorize it brings up my FB page in the web browser but doesn't give me the option to approve/authorize anything. Is there something I am missing or doing wrong? I have been trying to figure this out for a while now and just can't get it figured out. Please help!
Photo of Yves Crausaz

Yves Crausaz

  • 323 Posts
  • 45 Reply Likes
No problem for me LR CC to my time-line in FB
Photo of Brent Graham

Brent Graham

  • 2 Posts
  • 0 Reply Likes
Lucky you!
Photo of Aaron Tan

Aaron Tan

  • 8 Posts
  • 0 Reply Likes
I am using LR6. Ever since I changed my Mac, i have been getting these errors when trying to upload to Facebook/Flickr using 'Publishing Services'.

Facebook:
"Please make sure the 'Adobe Photoshop Lightroom' app has permission to upload to albums with the privacy level of this album. (In Facebook, look under Account Settings/Apps/Adobe Photoshop Lightroom/Posts on my behalf.)"

Flickr:
"Could not contact the Flickr web service. Please check your Internet connection."

However, I know for a fact that my Internet connection is ok. Otherwise, I wouldn't be able to post this.

I have also tried reauthorizing both on my Facebook and Flickr accounts. In the Lightroom Plugin Manager, both Facebook and Flickr plugins are yellow, with "Installed, may not work." Have tried reloading both plugins, and they will turn green. But the moment I close the window, and try uploading, get the error, and go back to the Plugin Manager, they will be yellow again.

Would be grateful if you could help me.
Photo of Brent Graham

Brent Graham

  • 2 Posts
  • 0 Reply Likes
Ditto. At least your recieving a response. I've sent comment after comment to no avail. My customers want to see their pics on FB asap!
Photo of Anita McKeith

Anita McKeith

  • 1 Post
  • 0 Reply Likes
This has not been solved. I've tried over the last couple of days to publish from LR to my FB page and it will only allow to do to my personal feed. And from there unable to share to my page. Aargh!!
Photo of J DAVID GIBB

J DAVID GIBB

  • 1 Post
  • 1 Reply Like
It is now January, 2017.  The above thread is reported 1-2 years old.  Since updating LR CC 2015 to v.8, the Facebook link isn't working.  When trying to publish a new photo, I get a message that the authentication check failed.  I don't even see a mechanism to uninstall/reinstall the plug-in.  The plug-in is reported as installed but may contain errors (yellow triangle).  Very frustrating as this forum is difficult to use and I don't even know if anyone reads this message.
Photo of Michele Marie Randolph Tiny

Michele Marie Randolph Tiny

  • 8 Posts
  • 0 Reply Likes
I have read your message and is going through similar problems.  FB is not acknowledging my albums any longer just from 15 minutes of setting up FB Publishing