Lightroom on UHD monitors causes severe mouse performance degradation

  • 2
  • Problem
  • Updated 4 years ago
Lightroom on UHD monitors causes severe mouse performance degradation for moments after performing photo edit operation in Develop mode.

Steps to reproduce:
-------------------------------------------------
See hardware setup below.

Import Raw image (im using Canon 6d in raw).
Edit image in Develop mode
Adjust Exposure

*Note: After the image has refreshed the mouse frame rate is dropped to less then a couple time per second for approximately a couple of seconds.

Moving mouse over other slide bars UI elements seems to be the root cause of the issue

Workaround
------------------------------------------------
Reduce the Lightroom.exe process priority to "Below Average".

This completely resolves the issue, but is annoying and something most Lightroom users wont figure easily.

This is typically indicative of windows paint handler being starved due to over use of Win32 messaging. By reducing the process priority of Lightroom, the application invalided the UI less during animations thus reducing starvation.

Consider reducing the frame rate of hover over animations, or reduces the render thread priority (this will also help with general UX performance, as the render engine will favor doping frames over UX response)

Thanks heaps!
Just upgraded from 4 to 6, and looking forward to using the HDR feature. Great work guys.
Just hoping that "command" bug has been fixed, the one where hot keys and UX commands with get muddled up. ie you would press Exit, and it would turn the current photo black and white.

Lightroom version: CC 2015 [1014445]
License: Creative Cloud
Operating system: Windows 8.1 Enterprise Edition
Version: 6.3 [9600]
Application architecture: x64
System architecture: x64
Logical processor count: 4
Processor speed: 2.6 GHz
Built-in memory: 7879.7 MB
Camera Raw SIMD optimization: SSE2,AVX,AVX2
System DPI setting: 144 DPI (high DPI mode)
Desktop composition enabled: Yes
Displays: 1) 1920x1080, 2) 3840x2160

Graphics Processor Info:
Intel(R) HD Graphics 4400
Photo of James Harper

James Harper

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 2
Photo of Matthias Henze

Matthias Henze

  • 13 Posts
  • 0 Reply Likes
Wow, thanks ... LR CC is now FAR more responsive, nearly as fast as LR5 used to be! Thank you!

When I read your post I come to the conclusion that this problem is a common one which is well known and Adobe should have been aware of this. The question is why has Adobes QM not seen this problem? Adobe: Please fix this.
Photo of James Harper

James Harper

  • 4 Posts
  • 0 Reply Likes
Probably find that the issue has always existed, its only the advent of ridiculous hi-res screens and speed of today's consumer level computers has "Unearthed" the issue.
Doubt they will fix anytime soon as it means making changes to their rendering framework, which could be a fairly big impact change.

In the mean while, if you want lightroom to start as "below normal" every time on it own, track down the link you use to open Lightroom with,
Left Click "Properties"
Click on the "Short Cut" tab

Where it says "Target" change the content to

C:\Windows\System32\cmd.exe /c start "Adobe Lightroom" /belownormal "C:\Program Files\Adobe\Adobe Lightroom\lightroom.exe"

This will unfortunately change the short cut icon to a ugly Cmd icon.
To fix this, in the Shortcut tab click "Change Icon"

In the "Look for icons in file" field, enter the path to the lightroom.exe which is probably
C:\Program Files\Adobe\Adobe Lightroom\lightroom.exe
this will show the Lightroom icon in the icon selection box.
Select the icon and this should set the right icon back on the Short cut
Photo of Matthias Henze

Matthias Henze

  • 13 Posts
  • 0 Reply Likes
At least for me this issue did not exist with LR5 on the same machine. The problem was introduced with the update to LR CC.

Thanks for the great tip for the start up!