Lightroom not updating after edit in Photoshop

  • 2
  • Problem
  • Updated 12 months ago
Since updating to Lightroom Classic CC and Photoshop CC 2018, edits in Photoshop are not showing up in the preview image in Lightroom. This bug was reported in earlier versions of Lightroom + Photoshop, but I didn't experience it then. It seems to me to have been introduced in the latest versions (running on Macintosh).

Has anyone else experienced this? I edit the photo by invoking Photoshop from Lightroom, then save in Photoshop and return to Lightroom, and the image shown in Lightroom doesn't change.

Synchronizing the folder in question does not seem to help. Usually I am able to fix it by Reading Metadata in Lightroom followed by Saving Metadata. Somehow the Save Metadata command gets Lightroom to realize that its preview is out-of-date.
Photo of Alan Harper

Alan Harper

  • 430 Posts
  • 85 Reply Likes

Posted 12 months ago

  • 2
Photo of Tom Mickow

Tom Mickow

  • 314 Posts
  • 104 Reply Likes
Yeah, I'm seeing it too, although it's not 100% repeatable for me.  If I could figure out a sequence of events that reproduced the problem, I'd have reported it myself.

As it is, previews in general seem to be acting really funky since the 7.0/7.01 releases.  Not only are they not updating when returning from external editors, like Ps CC, but they're also not updating when going between Develop & Library within Lr itself.

Example - I just imported a batch of raw images with the option to build 1:1 previews.  I culled through the images in Library loupe view, zooming in & out, etc.  No problems.  I then went back to the subset I had chosen and made some minor changes in Develop - applied a camera profile, lens corrections, and a couple adjustments in the Basic panel - and then sync'd those changes across all the images .  Next, I went back to Library for some additional culling.  The previews shown in the grid updated with the adjustments I had made, but when zooming to 1:1 in loupe mode, they were a pixelated fuzzy mess - certainly not the properly rendered 1:1 preview.  I tried rebuilding previews, going back & forth to Develop again, making sure my GPU was off, and so.  Nothing worked...until I restarted Lr and poof...problem solved.
Photo of RICHARD CASSEL

RICHARD CASSEL

  • 23 Posts
  • 6 Reply Likes
I have had this problem in earlier versions but not in the latest updates. Adobe customer support was able to provide me with a way to re-sync that I cannot currently recollect. Seems to be an intermittent problem, one that I have not seen since upgrading to CC Classic and PS 2018.