Lightroom Classic: Not syncing changes made on an iPad

  • 1
  • Problem
  • Updated 9 months ago
  • (Edited)
I am using Lightroom Classic CC where I create collections which are synced through cloud and then I am doing pre-selection and pre-edit photos on my iPad in Lightroom CC. Afterwards I switch back to my PC and I am finalizing my pictures back in Lightroom Classic CC.
But lately very often I am seeing issues where not all of the changes made on iPad are synced back to my PC. Usually it is like 5-10% changed photos are synced back. And it is not always 100% reproducable issue.
I have checked - all changes are correctly transferred to the cloud and I see all the changes in Lightroom CC on my PC. But these changes are missing on Lightroom Classic CC.
Till now I have used a method with deleting "Sync.lrdata" which force Lightroom Classic CC to synch all changes back from the cloud but it is very time consuming.
I need a fix or some other way to force synch selected catalog or photo with cloud content.
Photo of Michał Łuczycki

Michał Łuczycki

  • 7 Posts
  • 1 Reply Like
  • frustrated

Posted 9 months ago

  • 1
Photo of Paul Grant

Paul Grant

  • 40 Posts
  • 12 Reply Likes
Same here
Photo of Frank Kohn

Frank Kohn

  • 17 Posts
  • 0 Reply Likes
I'm trying to synch collections but they don't appear on my ipad in a separate collection, only in a huge file with any other photos. And everytime I use the program it tells me photos are still synching. Used to work flawlessly.
Photo of Arjun Haarith

Arjun Haarith, Employee

  • 92 Posts
  • 23 Reply Likes
Hi Michal,

Were all those photos uploaded to cloud successfully ? You can check it from https://lightroom.adobe.com/
Which version of Lightroom are you using?

Thanks,
Arjun
Photo of Arjun Haarith

Arjun Haarith, Employee

  • 92 Posts
  • 23 Reply Likes
Can you Go to -> Preferences -> Lightroom sync -> Press options /alt -> Click on Rebuild Sync data.  This will restart Lightroom in few seconds and rebuild your syncing. (Don't worry it won't delete or redownload your file).

Let me know if that helps

Note: This option is implemented on the newly released classic version (which was launched 2 days ago)
Photo of Michał Łuczycki

Michał Łuczycki

  • 7 Posts
  • 1 Reply Like
That's a great news. I will check this for sure next time I see the issue. For last issue occurrence I already removed and redownloaded all the data from cloud.
I am already using latest version - I always install updates as they are released :)
Photo of Arjun Haarith

Arjun Haarith, Employee

  • 92 Posts
  • 23 Reply Likes
Did this help Michal ?
Photo of Michał Łuczycki

Michał Łuczycki

  • 7 Posts
  • 1 Reply Like
Didn't see the issue yet - I'll let You know as soon as it reproduces again.
Photo of Michał Łuczycki

Michał Łuczycki

  • 7 Posts
  • 1 Reply Like
After last Lightroom update I didn't see this issue yet. Bu I will let You know when / if I see it.
Photo of Jeff Lopez Photography

Jeff Lopez Photography

  • 23 Posts
  • 6 Reply Likes
I've seen the same exact issue, very random and there's no algorithm to the error. Sometimes it's just 1 picture out of about 60 that doesn't sync to Classic, sometimes a handful wont', sometimes everything syncs. Very frustrating because I feel like now I'm constantly checking to make sure everything syncs over. And when I'm editing a wedding you can imagine the frustration of just "making sure" all 400-500+ are syncing correctly.