Lightroom: Latitude/longitude improperly rounded when stored in metadata preset

  • 3
  • Problem
  • Updated 4 months ago
  • Solved
When you create a metadata preset using Save Current Settings As New Preset, LR incorrectly rounds the coordinates of the selected photo to the nearest second before saving them in the preset.   When the preset is applied to another photo, it will get the rounded coordinates, rather than the original.    On average, this can result in the second photo being about 17m / 55' away from where it should be.

Tested in LR CC 2015.10 / OS X 10.12.3.

To reproduce:

1. In the Map module, select a photo A in the filmstrip.

2. Paste these coordinates into the Metadata > Location > GPS field:

37.899630, -119.221138

(which is 37° 53' 58.668" N, 119° 13' 16.0968" W).

3. In the Preset dropdown, select Edit Presets.

4. Do Check None and then check the box to the right of GPS.

5. Save the preset as "Test GPS".

6. In the filmstrip, select another photo B and apply the metadata preset Test GPS.

7. Zoom in the map all the way and observe that photo B is about 12m from photo A.

8. Open the file "Test GPS.lrtemplate" and observe that it contains the coordinates incorrectly rounded to the nearest second:

["com.adobe.GPS"] = "37°53'59\" N 119°13'16\" W",

9. Use the command File > Plug-in Extras > Show Catalog Metadata > Show from this plugin and observe that LR has stored photo A's coordinates in the catalog correctly, without rounding:

    gps = {latitude = 37.89963, longitude = -119.221138}

----------------------------
A very inconvenient workaround is to obtain the exact decimal coordinates from the Show Catalog Metadata plugin and paste them into the GPS field of the preset.

This bug may be related to another longstanding bug, where LR displays coordinates in the Metadata panel rounded to the nearest second: https://feedback.photoshop.com/photoshop_family/topics/gps_coordinates_cannot_be_entered .  

But it may be a completely different code path, so the bug reports shouldn't be merged.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3724 Posts
  • 975 Reply Likes

Posted 1 year ago

  • 3
Photo of Melissa Rios

Melissa Rios, Lightroom Support Product Manager

  • 104 Posts
  • 25 Reply Likes
Official Response
Hi all,

This issue should be fixed in today's Lightroom Classic CC 7.2 version. Please update your application and let us know if you still see this issue!

Lightroom Classic CC 7.2 is now available!

Thanks,
Melissa