Lightroom HDR images have uncorrected timestamp

  • 2
  • Problem
  • Updated 2 years ago
I have 3 raw photos that I took in another timezone (without adjusting my camera's time).  When I got home, I imported, corrected the timestamps in Lightroom, then merged them with the HDR feature.  The resulting HDR image has the uncorrected timestamp from the raw photo(s), which puts it out-of-order in the library.

I assume if I save the corrected metadata to disk, the problem will be resolved, but that shouldn't be necessary.
Photo of Mark McDuff

Mark McDuff

  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Just Shot Me

Just Shot Me

  • 210 Posts
  • 54 Reply Likes
Not sure why you bothered to change the Time Stamp on the images. This in itself would place those images Out Of Order from all other images in your catalog.
The only time I would adjust the Date-Time Original or Digitized is if the camera clock was set incorrectly, like several hours or Days off. If the date and time was set correctly on your camera for your Home location then all images, shot either at home or in any other Time Zone, will be in order when you get back home.
Does anybody really know what time it is. It is always Cocktail time someplace on this earth.
Photo of Mark McDuff

Mark McDuff

  • 3 Posts
  • 0 Reply Likes
@Just Shot Me, I changed the timestamp on all photos from that camera.  They were 10 1/2 hours off.
Photo of Mark McDuff

Mark McDuff

  • 3 Posts
  • 0 Reply Likes
I also tried saving the metadata to file before creating the HDR--same problem.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1397 Posts
  • 565 Reply Likes
Lightroom has a separate setting for saving time changes into (proprietary) raw files. That is not the same as 'Save Metadata to File', which does not save metadata into the proprietary raw files, but saves an XMP file with the raw file. It's all the way at the bottom of Catalog Settings - Metadata.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3691 Posts
  • 963 Reply Likes
This bug was fixed (for the second time) in CC 2015.5 / 6.5, and I just verified it is still fixed (at least in my CC 2015.8):

https://feedback.photoshop.com/photoshop_family/topics/lightroom-cc-mind-adjusted-photo-capture-time... 

Please do Help > System Info and report the exact version you are running.  If you have earlier than 2015.8 / 6.8, then do Help > Updates.