Lightroom: German keyboard shortcut for Group Into Stack broken

  • 3
  • Problem
  • Updated 8 months ago
  • Solved
  • (Edited)
[LR 8.0 broke this again, and Adobe has reopened the bug. See All Replies.]

LR 7.4 broke the keyboard shortcut for Group Into Stack for German. For previous versions, it was assigned to Cmd/Ctrl+G. But in 7.4, Preferences is also assigned to Cmd+G (Preferences was previously assigned to Cmd+W).

The workaround (and Adobe's fix) is to change this line in TranslatedStrings_Lr_de_DE.txt:
"$$$/Application/Menu/Edit/Preferences/KeyWin=Cmd+g"
back to the original:

"$$$/Application/Menu/Edit/Preferences/KeyWin=Cmd+W"
(LR 7.4 makes no other assignments to Cmd+W.)  See this article for editing TranslatingStrings:

https://www.lightroomqueen.com/custom-keyboard-shortcuts/


Yet again, no quality assurance for changes to keyboard shortcuts. At a minimum, before allowing a change to TranslatedStrings to be checked into the main branch, there should two people doing a "diff" and reviewing each edit.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4596 Posts
  • 1242 Reply Likes

Posted 1 year ago

  • 3
Photo of Axel Matthies

Axel Matthies

  • 12 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Shortcut CTRL-G for stacking pictures doesn't work in German version.

Shortcut Ctrl - G for stacking pictures doesn't work in the German version of Lightroom Classic CC (version 7.4).
If pressing CTRL-G it opens the Preferences dialogue.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5986 Posts
  • 1317 Reply Likes
Lightroom Classic CC 7.5 was released today and should address this issue.  If you don’t see the update in your Creative Cloud App, hit the [Ctrl/Cmd]+ [Alt/Opt]+[R] to force a refresh. 

Give the new version a try and let us know if it solves the issue. 
Photo of Axel Matthies

Axel Matthies

  • 12 Posts
  • 1 Reply Like
I've installed the update to version 7.5. The shortcut ctrl + G is working now. I thin the issue was solved.
Photo of Daniel Sarlette

Daniel Sarlette

  • 1 Post
  • 0 Reply Likes
Problem is back with LR8.0 !!!
Photo of Axel Matthies

Axel Matthies

  • 12 Posts
  • 1 Reply Like
After installing the update to Lightroom 8 the problem is back again.

The workaround to fix is the same as wrote above.



Changing this line in TranslatedStrings_Lr_de_DE.txt:

"$$$/Application/Menu/Edit/Preferences/KeyWin=Cmd+g"

back to the original:

"$$$/Application/Menu/Edit/Preferences/KeyWin=Cmd+W"

Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5986 Posts
  • 1317 Reply Likes
Thanks for the reports and additional information. I've reopened the issue with the team. 
Photo of Emmo Lempert

Emmo Lempert

  • 1 Post
  • 0 Reply Likes
still not fixed.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4562 Posts
  • 1221 Reply Likes
Unfortunately, you'll have to apply the workaround described in the first post.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5986 Posts
  • 1317 Reply Likes
Official Response
Greetings

Updates to Lightroom Classic CC (8.2), Lightroom CC for desktop (2.2), Lightroom CC.Mobile (Android and iOS) were released on Monday, February 11, 2019. Please verify that your issue is fixed by the current update.

Thank you for your patience.
Photo of Axel Matthies

Axel Matthies

  • 12 Posts
  • 1 Reply Like
After installing Lightroom Classic CC (8.2) the issue seems to be fixed. I've tested the shortcut CTRL + G and it worked fine.

Photo of John R. Ellis

John R. Ellis, Champion

  • 4562 Posts
  • 1221 Reply Likes
...and I checked the TranslatedStrings file, and it looks correct.  I'll mark this as Solved.