Lightroom Mobile (iPad): Not showing presets and issues syncing

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)
I recently bought the latest iPad Pro model from Apple. I have the 11 inch iPad Pro 2018 model. I downloaded Adobe Lightroom for iPad (which I didn't even know Adobe developed a separate lightroom program specifically for iPad) and I have no idea how to get my presets installed on my iPad. I have a Apple Macbook Pro and both Lightroom and Lightroom CC on my Macbook Pro already has presets installed. When I downloaded Lightroom for mobile (Lightroom mobile CC for my iPhone X), My presets were already synced and there on my phone from Lightroom CC. I should also mention that I have the latest version of both Lightroom Classic and Lightroom CC. I paid for the full Adobe Creative Cloud subscription.



I talked with an Adobe agent last night and the Adobe agent told me that my presets were incompatible for iPad... I was really confused because I could see the presets just fine on my iPhone and I didn't understand why it wasn't showing up on my iPad. When I saw the presets on my iPhone and laptop, I just assumed that it would be ok on my iPad. I also double-checked my accounts and everything is correct. I logged in and out of adobe lightroom on all devices (laptop, iPad, and iPhone) countless of times, double-checked my WiFi connectivity (that was fine as well) and did everything else that the agent told me to try including what I thought would help, etc and nothing was really working on my iPad. I could see the presets and my photos just fine on my iPhone and laptop but I could not on my iPad as it was just showing a black background.



As for the syncing, Adobe said that my photos were having issues syncing to my iPad, and for that I was also confused because I see them just fine on my iPhone and iPad. The only way I am able to see my photos is if my photos were imported from my iPad into Lightroom CC, NOT importing through my laptop or iPhone. All of my photos are saved on my local library through Lightroom CC and I could see them just fine on iPhone and laptop but for some weird reason I cannot with the iPad. I just see a black background on my iPad and the 'smart preview' is turned on, auto import is turned off, etc.  I checked the sync settings on all three devices as well and everything was correct. But i'm not sure why the iPad is having a hard time syncing. It just keeps spinning a blue color and showing the three dots on the cloud as it's syncing. It just seems like it's not doing anything to sync my photos so they would show up. I see the numbers total of how many photos I have but they're not showing up. The other weird thing is if I imported the photos from my iPad, I am not seeing them appear on my laptop top and iPhone. So I decided to leave it syncing overnight and I woke up this morning and checked on it and it is STILL syncing and still showing the black background and the presets are still not loaded in. My colleauge has the same presets as I do and he was able to use his on his iPad Pro (same model as mine) and see all of his photos just fine. The agent also had me try upload a photo through Lightroom web and I could see it just fine on my iPhone and Lightroom CC desktop but I could not with the iPad. I also was able to see the presets through the Lightroom web as well. This whole situation has me completely stumped and I'm not sure what exactly is going on.
Photo of Kirsten Pribula

Kirsten Pribula

  • 3 Posts
  • 1 Reply Like
  • Frustrated and confused

Posted 1 month ago

  • 1
Photo of Peter Obermeier

Peter Obermeier

  • 60 Posts
  • 30 Reply Likes
Hi Kirsten, are you working with LR CC and LR Classic in parallel and only smart previews are in the cloud? What do you see when you type http://lightroom.adobe.com/ in the browser on your iPad pro?
Photo of Kirsten Pribula

Kirsten Pribula

  • 3 Posts
  • 1 Reply Like
Hi again! 

My issue somehow resolved when I went to lightroom.adobe.com on my web browser on my iPad pro. I simply uploaded a photo through the web browser on my iPad pro and I checked on my desktop and iPhone to make sure I'm seeing it and they appeared. Then I went into the Lightroom app on my iPad and I'm now seeing the two photos that were black and now my presets just appeared! I'm not sure how that happened and I'm not sure why it's suddenly working after I was having such a hard time last night. 
Photo of Kirsten Pribula

Kirsten Pribula

  • 3 Posts
  • 1 Reply Like
Hi Peter!

Yes, I mainly work on Lightroom Classic. But I'm starting to switch over to my iPad to do my photo editing since it's starting to become more convenient for me. When I was talking to the agent last night, he had me turn on smart previews to see if the previews would show up in the library since I've been seeing black backgrounds. With that turned on, I'm not seeing the photos show up at all. I'm not really sure he knew what issues I was running in with my iPad on Lightroom so I decided to take my issues here. As for the web browser, I haven't tried that yet. Let me try that really fast!
Photo of Peter Obermeier

Peter Obermeier

  • 60 Posts
  • 30 Reply Likes
Hi Kirsten, great to see that your test pictures and the presets are visible now, but the trouble is not over.
There is no real good sync between LR Classic and CC. I had the same configuration and worked with plugins from Geoffry Friedl, but finally switched completely to LR CC 1TB. If you are interested then I could explain more in detail.
Best regards
Peter