Lightroom for Apple TV won't complete launch

  • 1
  • Problem
  • Updated 3 days ago
  • Acknowledged
I've been frustrated with this one for some time. I cannot get Lightroom on my Apple TV 4 (the HD version) to open fully.

It starts to open, and I get a picture background with a twirling busy wheel, but it just never launches completely, and eventually just quits back to the home screen.

I've tried various tricks, such as deleting and reinstalling, and even resetting the Apple TV itself, all to no avail.

I did manage to get it to launch a couple of time last year, but it took ages to get there.

I leave everything to auto update, so it's usually fully up-to-date at any time.

Lightroom is working fine elsewhere (iMac Desktop, iPhone, iPad and Web version).

Any suggestions?

Thanks.
Photo of Andy Hewitt

Andy Hewitt

  • 117 Posts
  • 18 Reply Likes

Posted 2 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7535 Posts
  • 1726 Reply Likes
I just installed Lightroom TV on my 4K Apple TV and signed into my Adobe ID. It launched and synced down the cloud content with no issue. (I've been running it for years on the HD version with no issues)

What is the free space on your Apple TV?
Can you verify the iOS version currently on your Apple TV? 
How many assets do you have in the cloud?
(Edited)
Photo of Andy Hewitt

Andy Hewitt

  • 117 Posts
  • 18 Reply Likes
OK Rikk, I'll try an uninstall and reinstall again. Although it is showing as V2.01 installed, which according to the site blurb is the newer version (the old one stopped at v1.2.3).

It does start to run, but sticks at the spinning wheel for ages, before it quits - it does even show some nice pictures while it's doing it.

Regards
Photo of Charlie D

Charlie D, Official Rep

  • 821 Posts
  • 88 Reply Likes
Hi Andy 
Thanks for taking the time to report this issue.  I'd like to get a bit more info, and hope to troubleshoot this with you.

I updated to the latest tvOS on both my 4th Gen (HD) and also 4K Apple TV devices, and installed the app again.   On my own large account (84,000 images, 400+ albums) the app did momentarily seem to get stuck loading my account after signing in.  Within a minute though, it resumed loading.  It sounds like you tried waiting too and this didn't help.

I know you tried re-installing the app already.  I wonder if forcing your account to reload helps.  Can you go into Lightroom TV app settings, towards the top right of our app.  In Settings, select Reload Albums.  Does that help?

Just curious -- if you sign into your account in a web browser at lightroom.adobe.com, near the top of the left side panel where albums are listed, do you see any reports of images that have sync issues?  I'm just trying to get an idea of what's different between our two accounts.

Thanks,
Charlie
Photo of Andy Hewitt

Andy Hewitt

  • 117 Posts
  • 18 Reply Likes
Hi Charlie

Thanks for looking into this.

I leave the app running, but eventually it just quits back to the main menu.

In the past, I have already tried re-installing, and even completely resetting the Apple TV box and reinstalling all the apps. My reinstall today of Lightroom didn't work either.

I've also tried rebooting the modem/router (broadband is good here, I get around 50Mbps downstream, and 19Mbps upstream). I've also switched between Ethernet and WiFi (the router is three feet away from the AppleTV box).

I can't get as far as reloading the account, it quits before it gets that far - it doesn't get to the folders/albums screen, I only see the initial loading screen, with the pretty photo and a progress animation.

There are no sync errors showing, and all other devices (web, desktop, iPhone and iPad) are all working perfectly fine.

I do have a folder/album structure that mimics my older Lightroom Classic layout, and there are over 4600 albums in my collection - is that perhaps a factor? (although it loads pretty quick in all other devices).

Cheers
Andy
(Edited)
Photo of Charlie D

Charlie D, Official Rep

  • 821 Posts
  • 88 Reply Likes
4600 albums could certainly be the critical factor here.  I'll log a bug noting the details you shared.  Thank you, Andy!
Photo of Andy Hewitt

Andy Hewitt

  • 117 Posts
  • 18 Reply Likes
Thanks Charlie.

These are of course a well laid out set of folders and albums (was previously Collection Sets and Collections of course) covering 20 years of digital photos. It could be difficult to 'rationalise' that.

Regards

Andy
Photo of Andy Hewitt

Andy Hewitt

  • 117 Posts
  • 18 Reply Likes
Hi Guys,

Just an update to this in that the recent update hasn't changed anything here, I still can't open Lightroom on my AppleTV.

Would it be an idea to remove and reinstall it?

Cheers
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7535 Posts
  • 1724 Reply Likes
I am able to successfully launch although I did have to reauthorize via a browser and re-enter the 6 character code. Verify your installed version is 2.1. 

If it is, a reinstall would be advisable. If not then an update would be advisable. 
Photo of Andy Hewitt

Andy Hewitt

  • 117 Posts
  • 18 Reply Likes
Yes, it was v2.1.

I've tried an uninstall (and reboot), and then reinstall, it launches, but is just stuck on the opening screen with the rotating dots and a background photo. I left it for 45 minutes, and it still hadn't completed launching.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7535 Posts
  • 1724 Reply Likes
  1. Verify TvOS is up to date with Apple
  2. Uninstall Lightroom TV 2.1
  3. Disconnect Apple TV from power
  4. Wait 5 minutes
  5. Reconnect Power
  6. Install Lightroom TV 2.1
The above is a clean install procedure designed to clear any residual information from the Apple TV with regard to Lightroom. 

FWIW, I checked on an Apple TV Gen 3 and an Apple TV 4K and both launch with no issues.  What gen is your Apple TV?
Photo of Andy Hewitt

Andy Hewitt

  • 117 Posts
  • 18 Reply Likes
Thanks Rikk,

OK, done the 1-6 list, it launched as it has done so far, with the 'Lr' logo and three rotating spots, then after a couple of minutes it just quit back to the main menu.

I'm running it again, and it's run for longer, but still not getting past this screen as yet.

FWIW, I assume you really mean a Gen 4 HD (I also have a Gen 3, which was the last of the iOS, non-Apps capable models, and not capable of installing Lightroom at all). It's the Apple TV HD (Gen 4) I am using here, the model below the 4K.

Cheers.

Andy