Lightroom: Fetch Altitude For Coordinates doesn't display altitude

  • 1
  • Problem
  • Updated 1 month ago
The Fetch Altitude For Coordinates button (to the right of Altitude in the Metadata > Location panel) doesn't display the fetched altitude when multiple photos are selected in the Map module's filmstrip. To reproduce:

1. Select three photos that don't have any GPS coordinates or altitude set.

2. Go to the Map module.

3. Drag the three photos to some point on the map. 

4. Click the Fetch Altitude For Coordinates button.

5. Observe that Altitude incorrectly remains blank.

6. Select each of the photos individually and observe that Altitude is filled in from the map.

7. Select all three photos and observe that the Altitude now appears filled in.

Tested on LR 8.2 / Mac OS 10.13.6.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4120 Posts
  • 1086 Reply Likes

Posted 1 month ago

  • 1
Photo of Yves Crausaz

Yves Crausaz

  • 323 Posts
  • 45 Reply Likes
idem Tested on LR 8.2 / Mac OS 10.14.3
Photo of Smit Keniya

Smit Keniya, Employee

  • 214 Posts
  • 97 Reply Likes
Hi John,

Are you facing this all the time or intermitently? 
Photo of John R. Ellis

John R. Ellis, Champion

  • 4120 Posts
  • 1086 Reply Likes
I did the recipe several times, and it happened each time.
Photo of Smit Keniya

Smit Keniya, Employee

  • 214 Posts
  • 97 Reply Likes
Was there any change after restarting Lightroom Classic?
Photo of John R. Ellis

John R. Ellis, Champion

  • 4120 Posts
  • 1086 Reply Likes
Unfortunately not -- restarting the computer and LR has no effect. 
Photo of John R. Ellis

John R. Ellis, Champion

  • 4120 Posts
  • 1086 Reply Likes