Lightroom Edit in Photoshop 2020 won't open photo if backup hard drive is running.

  • 1
  • Problem
  • Updated 4 months ago
See the knowledge base article "Lightroom ... edit-in photoshop command not working".

I have reinstalled software several times but it won't fix this problem.

My question -- how do I request that Adobe correct this behaviour in a future update?

The "fix" is more trouble than the initial problem. I have two additional hard drives/partitions installed in my Mid 2010 Mac Pro -- one is used exclusively for a Time Machine Backup, another is used by Carbon Copy Cloner to keep a clone of my boot drive that is updated once per day. 'Edit in' works properly if I move BOTH to the trash.

I have two work-arounds — (a) create a custom plugin for Photoshop (which an Adobe tech did when he took control of my computer earlier today) or (b) make sure Photoshop is already open when working in Lightroom.
Photo of BOB STEVENTON

BOB STEVENTON

  • 3 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Carlos Cardona

Carlos Cardona

  • 777 Posts
  • 149 Reply Likes
Bob: not sure what is causing your issue. Let's try stuff. What is your OS please? In the meantime...

If Catalina, go to System Preferences > Security & Privacy > Privacy tab. Unlock the lock at the bottom. Select Files & Folders down the left hand side and make sure Lightroom is listed & all of its checkboxes are checked? (If Lightroom is not in the right-hand pane, just drag/drop the app there).

Any OS: Try Onyx to rule out a corrupt cache or application state, instructions below (I was a Mac IT pro for 25 years).

Download the free Onyx (https://www.titanium-software.fr/en/onyx.html), select the Onyx version for your OS, download, run it, reboot.

In Onyx run almost everything in the Maintenance tab, deselecting things you may not want deleted, like Launch Services . Hit the "Options" button across from Internet and deselect more stuff like Cookies & Other Site Data, Browser History, Form Values, etc. (most of these are OFF by default). If you don’t know what something is, google it, or don’t run it, or ask me), then hit Run Tasks. After it's done it will ask for a reboot.

Also try to fix any directory damage by running Disk First Aid from Disk Utility: boot into Recovery Mode, (hold down Command-R when booting). When you're in Recovery Mode go to the Utilities menu and launch Disk Utility, say Repair Disk. When done go to Apple Menu for Startup disk and restart normally.

If Disk Utility says it can't fix it, run Disk Warrior ($120), (https://www.alsoft.com) from an external boot drive, reboot.

Also just doing a "Safe Boot" can clear out caches (restart, hold down shift until you see "Safe Boot" on the screen, let it fully boot, then reboot normally.

If that doesn’t work try launching Lightroom from your other (admin or test) account, with a new catalog, as a test. Does it run OK? If it does it may be a corrupted preference in your Username/Library folder. To reset your LR preferences: 

1. Close Lightroom. 

2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 

3. Overwrite the Preferences when prompted by the dialog. 

4. Close Lightroom. 

5. Restart Lightroom. 

Let me know if anything works, and what fixed it?

Photo of BOB STEVENTON

BOB STEVENTON

  • 3 Posts
  • 0 Reply Likes
Thanks for taking so much time to send me the above suggestions.

I have a mid 2010 Mac Pro with 48 GB of Ram and an upgraded graphics processor. It is running macOS 10.14.6, Sadly, Catalina is not compatible with the 2010 and 2012 Mac Pros so Mohave is as far as I can go. Both Photoshop and Lightroom Classic are the most recent versions. I have 2 SSDs and 3 hard drives in the computer -- and a total of 8 partitions. 

The problem was that Lightroom Classic would not launch Photoshop when I used the "Edit in" command. I tried all the usual fixes on my own, then with Adobe giving me help via an online chat and finally with an Adobe rep taking over my computer remotely to uninstall and reinstall software.

The problem hasn't been 'fixed' but I have now isolated it. The clue was in this knowledge base article: https://helpx.adobe.com/in/lightroom-classic/kb/edit-in-photoshop-command-not-working.html

I tried the suggested fix which was to remove the hard drive used by Time Machine from my system. That didn't solve the problem. I then removed the hard drive that is used by Carbon Copy Cloner to hold a clone of my boot drive. "Edit in" worked normally. I tested this again this morning -- "Edit in" will not launch Photoshop if the CCC clone is running but will launch Photoshop in the expected way if I eject that hard drive. (The Time Machine drive does not cause the problem -- perhaps Adobe has fixed that since the knowledge base article).

So the summary is: "Edit in" fails when the CCC clone drive is in my system but works normally when it isn't.

Thus my request: How can I pass this information on to Adobe for inclusion in their customer wish list for future updates?
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2913 Posts
  • 1251 Reply Likes
You already did. This is the forum to pass on such things.
Photo of BOB STEVENTON

BOB STEVENTON

  • 3 Posts
  • 0 Reply Likes
;-)