Lightroom: Doesn't recognize iPhone model information in metadata for videos

  • 3
  • Problem
  • Updated 1 month ago
  • Solved
  • (Edited)
Videos in lightroom from iphone do not show the camera model correctly in Metadata, it shows up as "unknown camera".

Iphone seems to use the "Model" metadata field for videos sometimes vs "CameraModel" and lightroom doesn't appear to look at Model today.  It would be great if lightroom could look for CameraModel first and then Model second.
Photo of andrewrbell

andrewrbell

  • 18 Posts
  • 4 Reply Likes

Posted 2 years ago

  • 3
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5278 Posts
  • 2078 Reply Likes
Which iPhone do you have?
Photo of andrewrbell

andrewrbell

  • 18 Posts
  • 4 Reply Likes
I tracked this all the way back through all of my iphones, 3gs, 4s, 5, 6/6p, 6sp, 7, 7sp.
Photo of Smit K

Smit K, Employee

  • 251 Posts
  • 125 Reply Likes
Hi Andrew,

I am able to reproduce this for iPhone 6s and 7. I have logged a bug for the same.

Thanks,
Smit Keniya
Adobe Lightroom Team
Photo of brainz

brainz

  • 3 Posts
  • 0 Reply Likes
Hi,

I'm facing the issue in iPhone X as well. Is there any fix, yet?
Photo of Melissa Rios

Melissa Rios, Lightroom Support Product Manager

  • 104 Posts
  • 26 Reply Likes
Hi all,

This issue should be fixed in today's Lightroom Classic CC 7.2 version. Please update your application and let us know if you still see this issue!

Lightroom Classic CC 7.2 is now available!

Thanks,
Melissa
Photo of andrewrbell

andrewrbell

  • 18 Posts
  • 4 Reply Likes
I just upgraded lightroom to get HEIC support on windows (not there unfortunately) and then thought, well, at least my iphone videos will have the proper data camera meta data now per this request, but checked and iphone videos are still shown with camera as "Unknown Camera" in Lightroom classic cc 7.4.
Photo of Smit K

Smit K, Employee

  • 234 Posts
  • 117 Reply Likes
Hi Andrew,

We are aware of this. We are working on this.
Photo of andrewrbell

andrewrbell

  • 18 Posts
  • 4 Reply Likes
This is still not fixed in version 7.5.  When will this be fixed?
Photo of andrewrbell

andrewrbell

  • 18 Posts
  • 4 Reply Likes
I see this bug was fixed but unfortunately just after the standalone lightroom no longer gets updates.

Can you see if an update can be pushed for standalone that just fixes this bug?
Photo of brainz

brainz

  • 3 Posts
  • 0 Reply Likes
Still doesn't recognise the camera details for videos shot on my iPhone 6, and 5s.
Photo of Smit K

Smit K, Employee

  • 234 Posts
  • 116 Reply Likes
Are you using default camera app or some other app for video recording? Also, could you share the sample video where you are facing this issue?
Photo of brainz

brainz

  • 3 Posts
  • 0 Reply Likes
Sure, most of them are personal, where can I upload them for you to see them privately?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6139 Posts
  • 1357 Reply Likes
Official Response
Greetings, 

The Lightroom Classic CC was updated today and contains a fix for this issue. Please download the new version and give it a try and let us know how it works.
Photo of agnieszka wiklendt

agnieszka wiklendt

  • 2 Posts
  • 0 Reply Likes
Using Lightroom Classic CC 8.4.1. Software does not recognise Olympus OMD E-M10 as creator for video files created in that device (lists as "unknown device") when selecting "Camera" in Metadata library filter. Also capture time is incorrect. Does not display "Camera Serial Number" for same.

Same issue with Huawei Mate 20 (not pro) phone, although capture time is correct, LR does not recognise device as creating the video. 

For Panasonic DMC-FT30, LR recognises camera for both JPG and MP4, but only serial number for JPG. MP4 are listed as "unknown camera serial number" in library filter "Camera Serial Number", even though DMC-FT30 is listed as the "Camera" in filters.
(Edited)
Photo of John R. Ellis

John R. Ellis, Champion

  • 4588 Posts
  • 1237 Reply Likes
The original topic was for a bug specific to iPhones and was fixed 12 months ago.

Please reference the new conversation here: Lightroom: Missing camera, capture time, and serial number for videos from variou...