Lightroom: Does not display RAFs previews in import dialog since 2015.7

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Since LR 2015.7, previews of the RAFs are not displayed anymore in the import dialog.
This is really annoying...

Photo of Régis Derimay

Régis Derimay

  • 18 Posts
  • 3 Reply Likes
  • sad

Posted 3 years ago

  • 1
Photo of Ganesh

Ganesh, Lightroom Engineer

  • 73 Posts
  • 23 Reply Likes
Hi,

Can you provide the camera model?

Thanks,
Ganesh
Photo of Régis Derimay

Régis Derimay

  • 18 Posts
  • 3 Reply Likes
FujiFilm X-T2 :-)
Photo of Just Shot Me

Just Shot Me

  • 391 Posts
  • 108 Reply Likes
Only when shooting Compressed RAW. 
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1636 Posts
  • 550 Reply Likes
Are you importing from a folder or directly from the canmera/card reader? Does the thumbnail show when you import from a folder? It might be helpful to share a sample image file. We could not reproduce internally. 

Windows or Mac? Is it working in the previous version of Lr for the same set of files?
(Edited)
Photo of Régis Derimay

Régis Derimay

  • 18 Posts
  • 3 Reply Likes
ok. so I was able to reproduce when it works and when not.

1. I import though the sd card reader integrated in my mac.
2. Using my camera connected by usb, it works. I dont' care, but it works...
3. It is not related to the type of card used.
4. It is not related to the preferences
5. It is not related to the catalogue.

The major diff is :
It does not work when choosing the "Device" > "Untitled" (the name of the card) 
It works when choosing  "Files" > "Untitled" in the Sources Pane and choosing to include the sub folders.

I shoot Fuji X-T2 Compressed Rafs
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1636 Posts
  • 550 Reply Likes
Official Response
Which version of Mac OS X that you have? When importing under the "Device" mode, Lightroom relies on the Mac OS X ImageCapture API to enumerate and provide the thumbnails from the device to display. It looks like the Mac OS X ImageCapture API does not understand Fuji X-T2 Compressed RAF file format. Try import with the "Files"/"Folders" mode as a workaround. Or try update your OS to the latest version of Mac OS X to see if the issue is fixed.
Photo of Régis Derimay

Régis Derimay

  • 18 Posts
  • 3 Reply Likes
Ok. good to know. I use the very last Sierra. (Updated to the 10.12.1 beta 5 this evening...
Thanks for this very effective help.

Could I kindly ask you to take a look to the bug I reported this morning on the custom WB and profiles not being taken over anymore ?

https://feedback.photoshop.com/photoshop_family/topics/lightroom-forgets-about-profile-and-white-bal...
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1636 Posts
  • 550 Reply Likes
Commented on that thread after talking to the engineer, 
Photo of Régis Derimay

Régis Derimay

  • 18 Posts
  • 3 Reply Likes
Thanks. I responded to you answer there, I think you are right only on a part of the answer. I you can take a look at my answer.
Thx.