Lightroom: Different histograms for identical copies of a raw file

  • 2
  • Problem
  • Updated 2 months ago
  • Acknowledged
Develop displays histograms for identical images with small but noticeable differences, and these differences depend on the order in which you edit the files.  By itself, this probably doesn't have any impact on users, but it may indicate a worrisome underlying bug in how Develop caches computations.

See this screen recording, and follow these steps precisely:

1. Download this sample raw into a folder and make a copy of the raw in the same folder. Rename the two raws A and B.

2. In LR, do Preferences > Performance > Camera Raw Cache Settings > Purge Cache. 

3. Restart LR.

4. Import A and B.

5. In Library, select A and make a virtual copy.

6. In Library, select A and Cmd-click B (order is important).

7. Go to Develop, and use the cursor keys to switch between A and B.  The histograms appear identical.

8. Go to Library.

9. Without changing the selection, go to Develop, and use the cursor keys to switch between A and B.  The histograms now have small but noticeable differences.

10. In Library, select A and Cmd-click the virtual copy (order is important).

11. Go to Develop, and use the cursor keys to switch between A and the virtual copy.  The histograms have small but noticeable differences.  

Tested on LR 8.3.1 / Mac OS 10.14.5.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4472 Posts
  • 1188 Reply Likes

Posted 2 months ago

  • 2
Photo of Kelly C.

Kelly C., Senior Lightroom QE

  • 86 Posts
  • 39 Reply Likes
Hi John,

It looks like the download link to your sample bug file has expired. Can you please repost it? I have yet to be able to reproduce the issue using various RAFs.

Thanks,
Kelly
Photo of Kelly C.

Kelly C., Senior Lightroom QE

  • 86 Posts
  • 39 Reply Likes
Got it, thanks.
Photo of Kelly C.

Kelly C., Senior Lightroom QE

  • 86 Posts
  • 39 Reply Likes
Thanks John. I can repro with that test file. I'll get it filed in our bug base and have a dev look into it.
Photo of Kelly C.

Kelly C., Senior Lightroom QE

  • 86 Posts
  • 39 Reply Likes
It looks like what is happening here is that Lr is showing the Histogram for the interim preview when switching from A to B, but is not updating (as it should) once the full negative loads. I don't expect any issue beyond the Histogram UI not updating properly in this case, and it should be an easy fix. Thanks for reporting it John.
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 1464 Posts
  • 492 Reply Likes
Kelly C., I can see the same issue in LR 8.3.1 with DNG Export files. It's very simple to duplicate. Reset a raw file (default settings applied), export it to DNG file format, and you expect to see the same histogram as the original raw file. The Library module histograms are identical, but not the Develop module histogram.

1.    If you apply any Develop setting to the DNG file and then set it back to 0 the histograms match.
2.    They will also match if you simply click on the reset button with the DNG file selected.
3.    Zooming to 1:1 view in the Develop module the histograms remain different.
4.    Zooming to 1:1 view in the Library module and back the histograms then match at all Zoom views.

I tested LR 8.2 with the Export module set to Compatibility Camera Raw 11.2 and later (i.e. matching versions) and it exhibits the same issue. I also tested LR 5.7.1 and it does NOT exhibit this issue.
(Edited)