Lightroom Classic: Updating to version 9 but my catalog from version 8.4 is incompatible

  • 2
  • Problem
  • Updated 2 days ago
  • Acknowledged
  • (Edited)
Lightroom Classic - Updating to Lightroom Version 9 but my catalog from version 8.4 is incompatible and for some reason, it can't be updated. I can revert back to 8.4 temporarily so as not to lose my collection of work but it's not going to be a solution long term. Can you help give me some steps that might offer a solution to this issue I am encountering?

Any advice, solution or steps that I might be able to try would be most appreciated.

Thank you.

Joe
Photo of Joe Kelly

Joe Kelly

  • 3 Posts
  • 1 Reply Like

Posted 1 week ago

  • 2
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2341 Posts
  • 963 Reply Likes
Do you get an error message and if so, what does it say?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5300 Posts
  • 2091 Reply Likes
Cyndi, at what stage are you seeing the missing volume? After you've opened the right catalog or the "other" catalog you need to open in that incompatible dialog?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5300 Posts
  • 2091 Reply Likes
Cyndi, at what stage are you seeing the missing volume? After you've opened the right catalog or the "other" catalog you need to open in that incompatible dialog?
Photo of Steve Gandy

Steve Gandy

  • 140 Posts
  • 44 Reply Likes
We have the same problem. Here's the error message. We are using Mac 10.14.5. Classic 9 refuses to open the catalog but reverting to 8.4.1 works. Help. Thanks in advance for your time and effort.
T
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5300 Posts
  • 2091 Reply Likes
It's now a confirmed issue, should be fixed in the next release.
Photo of Steve Gandy

Steve Gandy

  • 140 Posts
  • 44 Reply Likes
Excellent! We tried everything.

For anyone else out there with the issue. There is a file created each time with a -sync -2 at the end of the file name. We were throwing those out when we retested. And sometimes a lock file would be created. But we threw those out each time as well. 

The error message takes you to a page about deleting the lock files but that is _not_ the issue.

We also optimized the catalog each time we had it open in v8.4.1 so I believe the catalog is not corrupted.
Photo of David Golding

David Golding

  • 117 Posts
  • 15 Reply Likes
Try a cold reboot, worked for a couple  in the Adobe Support Community. No reason.

Photo of Steve Gandy

Steve Gandy

  • 138 Posts
  • 43 Reply Likes
Didn't work for us.