Lightroom Classic: Updating to version 9 but my catalog from version 8.4 is incompatible

  • 7
  • Problem
  • Updated 3 months ago
  • Solved
  • (Edited)
Lightroom Classic - Updating to Lightroom Version 9 but my catalog from version 8.4 is incompatible and for some reason, it can't be updated. I can revert back to 8.4 temporarily so as not to lose my collection of work but it's not going to be a solution long term. Can you help give me some steps that might offer a solution to this issue I am encountering?

Any advice, solution or steps that I might be able to try would be most appreciated.

Thank you.

Joe
Photo of Joe Kelly

Joe Kelly

  • 3 Posts
  • 1 Reply Like

Posted 7 months ago

  • 7
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7292 Posts
  • 1658 Reply Likes
Official Response
This should be resolved by the 9.1 update released earlier today. Please give it a try and let us know if you still see the issue after updating.  Thank you for your patience!