Lightroom Classic: Stuck on "preparing to sync" for hours

  • 3
  • Problem
  • Updated 7 months ago
  • (Edited)
I had to revert to a previous version of the catalog.
 The version is only a couple of hours old,    and there are no differences in the shared galeries between the two.
On startup, Lightroom re-synced all the shared pics in few minutes. Closed lightroom. On next startup, lighroom is stuck on "preparing to sync" .   On activity monitor, L has a high energy impact and CPU usage, that goes considerably down when sync is paused. 
Any idea?
Photo of Roberto Saltori

Roberto Saltori

  • 5 Posts
  • 1 Reply Like

Posted 7 months ago

  • 3
Photo of Antoine Hlmn

Antoine Hlmn

  • 804 Posts
  • 203 Reply Likes
Building smart previews before uploading them?
Does it show anything in the préférence sync page?
Photo of tpnotes

tpnotes

  • 84 Posts
  • 18 Reply Likes
As far as I remember the smart views used for syncing are different from the ones you can generate. So I assume, that would not make a difference.
Photo of Antoine Hlmn

Antoine Hlmn

  • 804 Posts
  • 203 Reply Likes
That could very well be true, but it has to generate some in order to upload them.

Have you tried:
Restart LR
Log out and in (has helped me a couple of times)
Rebuild the sync data
?
Photo of Roberto Saltori

Roberto Saltori

  • 5 Posts
  • 1 Reply Like
not sure about the smart previews. Normally I move the pics in the gallery and they sync.  In preference/sync it says preparing to sync ( no sync activities)

Photo of tpnotes

tpnotes

  • 84 Posts
  • 18 Reply Likes
I have had a corrupt sync at least three times during the last year and have not found a solution. You can try to rebuild the sync data (press Alt key in the sync settings an the button appears), but that have not worked for me.

What you see in case of a corrupt sync, is what you described above:  forever preparing, pending or stucked sync. Sometimes with high CPU usage, sometimes with non CPU usage. An indicator is the re-sync of all synced images. If you wait long enough, it often counts down really fast, then starts re-syncing over again and gets stuck somewhere.

The sync does not like e.g.:
- restoring catalogs (or restoring the iOS app from a backup)
- deleting images, while changes are still pending for syncing
- moving images to another folder, while changes are still pending for syncing
- missing dates in EXIF data
- quitting LR while sync is still in progess
- ...

Additionally, since LR Classic 8.4 I have noticed, that some syncing process are still active (see sync settings) even if the sync seems to be completed according the identity plate.

After spending several hours for trouble shooting in the beginning, I now start the sync from scratch when the sync starts to behave funny. That sounds like a lot of work, but since I was not successfull in restoring a corrupt sync it is less work than fruitless troubleshooting. 

Photo of Roberto Saltori

Roberto Saltori

  • 5 Posts
  • 1 Reply Like
tried to rebuild sync data, no result. 
What do you mean  " start the sync from scratch?"
 It seems the only solution at the moment...
Photo of tpnotes

tpnotes

  • 84 Posts
  • 18 Reply Likes
In upper widget of the sync settings is a button called something like "delete all synced data". If you hit this, all synced data will be deleted and you can start a completely fresh sync. Be aware that you will loose all information from Lr CC during that process.

BEFORE you hit this button:
- Please make sure, that you stop syncing for all synced collections. If you not do this, there is a near 100% chance that you will lose some or all collections (the collection itself or it will be emptied).
- If you have synced images, which are not in a collection, make sure, that you make a new collection for them, so you can easily re-add them later.
- If you have any images, which you have imported to Lr CC (Desktop or mobile), which are not yet synced to Lr Classic, make a backup outside of Lr CC of them, because they will be deleted during that process.

In my case I sync around 20.000 images. When I start over, I do not sync them not all at once, but in batches, collection by collection for example.

There is one other option you can try, before deleting all synced data: Prevent your computer from going to sleep and let the sync run over night or all day without touching Lightroom and see if anything moves.If anything moves, the sync might be get back on track by itself. This can take a couple of days, if you have as much images as I am.

If you search in this forum there are quite a few threads about stucking sync processes. Perhaps there might be more tips, which you want to try out before doing the deleting-thing.
Photo of Roberto Saltori

Roberto Saltori

  • 5 Posts
  • 1 Reply Like
Thanks, mate. 
I did as you suggested, and finally, I do have control of my collections back! As you say, better nightlong sync than frustrating hours looking for a solution. 
Photo of Roberto Saltori

Roberto Saltori

  • 5 Posts
  • 1 Reply Like
I logged out and in, now on the logo corner says syncing 2 photos ( I have 2 that should sync, in fact) but in preference/sync still preparing to sync/no sync activities  
Photo of tpnotes

tpnotes

  • 75 Posts
  • 15 Reply Likes
When you open up the sync settings, wait a few moments, if really nothing shows up in the lower widget. On my computer it takes several seconds, before anything shows up there. Significant longer than I normally would expect.

If you know, which images are affected, you can delete them manually from all synced photos and re-add them. That might work.