Lightroom Classic: Slow to Start

  • 3
  • Problem
  • Updated 4 weeks ago
  • In Progress
  • (Edited)
When I start LR Classic 9.2.1 on my Win 10 2004 system recently the Library starts to load but then seems to stall. If I then click on the stalled LR Classic app its splash screen pops up and I have the little system donut spinning. During this time the program appears to be locked up and not responding. After quite a delay of 1 to 1-1/2 minutes the thumbnails resolve, the library updates and all seems back to normal.
I tried a number of potential solutions:

1) Re-booted

2) Signed out and back into my Adobe account

3) Reset preferences

4) Disabled graphics card acceleration

5) Cleared the thumbnail cache

None of these solutions worked. After searching the internet I found a discussion where it was suggested that I disabled the LogiOptions plugin if installed. I did this and the problem disappeared. If I reenable the plugin the problem returns.

I recently replaced my Logitech mouse and keyboard, and installed their associated SW and new drivers. It appears that this also silently added the LogiOptions plugin to LR. What exactly the plugin does is not obvious. It likely has something to so with mouse button reassignments if one uses that Logitech option.

I sure wish vendors would make it clear up front what changes their SW is going to make to other applications already installed.
Photo of JC

JC

  • 130 Posts
  • 35 Reply Likes

Posted 4 weeks ago

  • 3
Photo of Brian Wall

Brian Wall

  • 17 Posts
  • 3 Reply Likes
Win 10 doesn't need Logitech software or utilities so I'd just zap them off your system. More trouble than they're worth.
Photo of Anthony Blackett

Anthony Blackett

  • 269 Posts
  • 73 Reply Likes
I have had this problem and reported it since Lr classic 8.3, yet I don't have any Logitech software installed on my laptop nor any other third-party mouse/keyboard drivers.

https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-8-3-splash-screen-displays-multiple-times-with-not-responding?utm_source=notification&utm_medium=email&utm_campaign=me_too&utm_content=topic_link

As you see, Adobe acknowledged the problem, but as yet there has been no fix forthcoming.

It continues to be a very annoying problem for me.

What I find most frustrating about these bugs that are introduced by Adobe, is that despite being told about them and being confirmed, the development team seems unwilling to fix them.

Photo of Brian Wall

Brian Wall

  • 17 Posts
  • 3 Reply Likes
Just how many users suffer from this though? 
(Edited)
Photo of Jerry Syder

Jerry Syder

  • 499 Posts
  • 227 Reply Likes
A lot. Even if it was one, it needs to be fixed. 
Photo of Brian Wall

Brian Wall

  • 17 Posts
  • 3 Reply Likes
What I was getting at is that if there is a fault in software it tends to affect the majority. If it isn't a software error then it must presumably be something in the individual setups. No amount of testing or planning can account for every variation of computer, nor indeed for the vagaries of the users. As an ex-support person, I can assure you the end-user is always the first suspect! AKA is it turned on? :-)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7545 Posts
  • 1729 Reply Likes
@Anthony your issue is different than the original posters and is still being actively worked on for anu upcoming release. 
Photo of Anthony Blackett

Anthony Blackett

  • 269 Posts
  • 73 Reply Likes
Thanks Rikk for the clarification. Hoping a resolution will come soon.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7545 Posts
  • 1729 Reply Likes
@JC - the solution, as you've found is to disable the Logioptions program (as I have done) and ask Logitech for a fix to the issue. 
Photo of JC

JC

  • 130 Posts
  • 35 Reply Likes
Thanks Rick. One of my tasks for today is to report this issue to Logitech.
Photo of Ronald Byram

Ronald Byram

  • 33 Posts
  • 4 Reply Likes
How do I look to see if I have this installed on my windows 10 pc?

Photo of JC

JC

  • 130 Posts
  • 35 Reply Likes
In Lightroom Classic go to File>Plug-in Manager. This will bring up the Plug-in Manager maintenance window. If the LogiOptions plug-in is installed it will be listed in the panel to the left. If so, you can disable there.
Photo of Ronald Byram

Ronald Byram

  • 33 Posts
  • 4 Reply Likes
Thank you! Verified I dont have that installed. But I did see other items that I dont need so U disabled..