Lightroom Classic Slideshow Module

  • 1
  • Idea
  • Updated 2 weeks ago
This concerns the slideshow module in Lightroom Classic. Previously, when new folders were added to my catalogue, and I wished to view them as a slideshow, for the first time there was a delay while the slideshow previews were prepared, but for any subsequent viewings, the delay was minimal.


Following the latest version of LrC a few days ago, every time I wish to view a folder, there is a lengthy preparation time. The only way to avoid this is to use fn F to view a manual slideshow using the arrow key to move forward. I want to let the show progress automatically with a standard display time.


Your Help Team have told me that this is now standard in the latest version of LrC. This really is not acceptable in a supposedly professional application, and a very backward move. I use LrC daily, and need to view my photos frequently. I cannot wait 2 minutes or more before each folder starts to play. Please address this issue as soon as possible.

Photo of Tim Bailey

Tim Bailey

  • 3 Posts
  • 0 Reply Likes
  • Irritated

Posted 3 weeks ago

  • 1
Photo of G0apher

G0apher, Employee

  • 110 Posts
  • 28 Reply Likes
Tim, Does the time to prepare the slideshow also include the time to generate the previews? Can you ensure the standard previews are created for the images in the Slideshow before trying to play the slideshow? 
Photo of Tim Bailey

Tim Bailey

  • 3 Posts
  • 0 Reply Likes
Yes, the time is taken up in preparing previews. The slideshow does not start until the previews complete, maybe two minutes or more depending on the folder size. 
Photo of G0apher

G0apher, Employee

  • 110 Posts
  • 28 Reply Likes
Thanks, Tim for checking.

Generating the standard previews will ensure the slideshow applies any edits or presets to the images, so they look as expected in the slideshow preview as well. If you had already generated the previews, it should not take much time when generating the slideshow. Could you please check if that is the case?

Photo of Tim Bailey

Tim Bailey

  • 3 Posts
  • 0 Reply Likes
In Slideshow, if I press the preview button, it prepares the previews. But then if I press play, it prepares the previews again before it actually plays. Before the recent update, once the previews had been generated the first time, there was no delay with subsequent  viewings. The person who replied to my chat enquiry said that this was standard on the latest version of LrC.
Photo of G0apher

G0apher, Employee

  • 110 Posts
  • 28 Reply Likes
Yes - that is the new behaviour. Though, if nothing has changed in the images, and previews are already available, the preview task should be completed quickly.

I have raised your issue with the development team, and we are trying to see how this can be addressed.

Thanks for reporting, and appreciate your patience.