Lightroom Classic: Problem with History Panel when in Reference View

  • 1
  • Problem
  • Updated 5 months ago
  • Not a Problem
While using the Reference View mode in Develop, I have noticed a problem with the History panel when going back in history. Sometimes, going back in history leaves the develop settings unchanged when in Reference View mode.

The issue I'm having is a little inconsistent, making it difficult to reproduce in a set of steps, but I've narrowed it down to a point where I can eventually get the problem to appear.

I had downloaded some RAW NEF files from the dpreview website to compare newer Nikon camera models to my D750. The example described here uses two D750 and D780 NEF files in Reference View mode.

1. Import the files.

2. In Develop, activate the Reference View and set the D750 file as the reference image, as shown in the screen shot below:

3. With the D750 image selected, set Auto WB and Auto Tone, as shown below:

4. Select the D780 image and set Auto WB and Auto Tone.

5. Select the D750 image (the reference) and on the History panel click the Import step to 'undo' the develop settings. At this point, the develop settings should revert to their original values, but sometimes the settings don't change, as shown below:

If the problem doesn't occur the first time, then from this point, with the Import step still selected in the History Panel on the reference image, I repeat this procedure:

6. Select the second image (D780), then reselect the reference image (D750), click the Auto Settings step in the History Panel, then click the Import step.

Repeating step (6) eventually seems to cause the problem, at least for my system. If step (6) is repeated many times, Lr seems to get very confused. If I minimise Lr after doing step (6), then restore the Lr window, it very slowly redraws elements of the Lr window, as these screen shots illustrate.

If Lr is left for a while, it seems to recover from whatever state it gets into and behaves normally again until I repeat step (6).

System Info:

Lightroom Classic version: 9.2 [ 202001311240-2d026470 ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.18363
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 2.1 GHz
SqLite Version: 3.30.1
Built-in memory: 16365.8 MB
Real memory available to Lightroom: 16365.8 MB
Real memory used by Lightroom: 1650.2 MB (10.0%)
Virtual memory used by Lightroom: 5819.3 MB
GDI objects count: 1119
USER objects count: 2542
Process handles count: 2184
Memory cache size: 0.0MB
Internal Camera Raw version: 12.2 [ 384 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX
Camera Raw virtual memory: 1062MB / 8182MB (12%)
Camera Raw real memory: 1084MB / 16365MB (6%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
DirectX: NVIDIA GeForce GT 525M (

Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic
Library Path: C:\Users\Tony\Pictures\Lightroom\Photography\Lr9 Photography.lrcat
Settings Folder: C:\Users\Tony\AppData\Roaming\Adobe\Lightroom

Installed Plugins:
1) AdobeStock
2) Facebook
3) Flickr
4) Nikon Tether Plugin

Config.lua flags: None

Adapter #1: Vendor : 10de
    Device : dec
    Subsystem : fc501179
    Revision : a1
    Video Memory : 1989
Adapter #2: Vendor : 1414
    Device : 8c
    Subsystem : 0
    Revision : 0
    Video Memory : 0
AudioDeviceIOBlockSize: 1024
AudioDeviceName: S27D590 (NVIDIA High Definition Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: 12.1x4
Direct2DEnabled: false

Photo of Anthony Blackett

Anthony Blackett

  • 274 Posts
  • 75 Reply Likes

Posted 5 months ago

  • 1
Photo of mariah


  • 15 Posts
  • 4 Reply Likes
Well, if the problem is not consistent then you do  not have to worry. Do one thing uninstall every files from your system and install it again. I guess your software has some bug, try updating it if reinstall method does not work.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7719 Posts
  • 1780 Reply Likes
I have tried to replicate this multiple times but have been unable to so far. 
Tested Mac 10.14.6 and Windows 10.
Photo of Anthony Blackett

Anthony Blackett

  • 274 Posts
  • 75 Reply Likes
Thanks Rikk,

It is a very odd one as I'm not able to repeat this with my own images either. I have just tried again with two pairs of RAW images, taken with my Nikon D750, imported into a new catalogue and I couldn't reproduce the problem.

I then imported the two RAW images I had downloaded from dpreview's website and tried with those and it immediately produced the problem as described in my initial post. Thinking it might have something to do with RAW files from different camera models (D750 and D780) I tried it with two D750 images from dpreview (different ISO) and it also occurred with those.

Here are links to two files from dpreview that I can reproduce the problem with regular consistency:

Can you try one last time with these two images?

Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7718 Posts
  • 1780 Reply Likes
It is possible the DPReview files are preproduction files so I wouldn't trust them as a source. Your production camera, with current firmware is a much more authoritative source for current images and expected behavior.