Lightroom Classic: Library preview not showing edits

  • 2
  • Problem
  • Updated 9 months ago
  • (Edited)
In library module the preview of an image is not updated after returning from developing module. The only way to get it to update from pixelated/lined view is by either rebuilding the 1:1 preview (i built those on import already) or by zooming in. So i have to 'force' LR to do this by performing an action. Waiting for it to happen without doing anything is not working. No noise reduction was applied in this image.

I developed two images with loads of blue (one blue paper one a blue sky) in develop module. If i go back to that image it takes a bit for the blue sky to 'smooth out' it looks lined and pixelated at first.Mac 10.11.6
LR Classic 7.0
32gb ram/i7
for now gpu unticked (NVIDIA GeForce GTX 780M 4096 MB)

PLEASE DO NOT MERGE WITH THE POST NOISE REDUCTION NOT SHOWING, IT IS NOT THE SAME ISSUE!!!!

A link to an image in dropbox, it is a screenshot of the blue as it is showing in library module https://www.dropbox.com/s/xi0sshuahoojlnw/Screen%20Shot%202017-11-04%20at%2016.36.59.png?dl=0
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes

Posted 1 year ago

  • 2
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
I agree, this is not a noise reduction issue. It is far more coarse pixelation than noise. It looks like a a VGA picture. I have the exact same issue as Kitty.
Windows 10 home, version 1703.
LR Classic 7.0
16gb ram/i7
The problem exists regardless of whether the GPU is unticked. NVIDIA GeForce GTX 960M 4096MB.
I've attached an example. Look at the blue sky. It is fixed only after rebuilding 1:1 previews or entering the develop module and waiting a few seconds.
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
The image in library module after returning from develop, if i do nothing it will keep showing it in this blue pixelated lined way

And a closeup screenshot after zooming in in library module but before it got smoothed out 

And the way it should be and shows after zooming in and out
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
To prevent the suggestion of using smart previews: i just changed so i use the smart preview of this bird pic (moved the image to another folder on the HD). Very interesting is that in library i get that same pixelation but zooming in does not smooth it out at all! 
EDIT: went to 10.12.6 in the mean time, issue is still there.
(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1486 Posts
  • 468 Reply Likes
Do you have the new color range masking applied on the photo?

What is the size of your Lightroom Standard Preview size (in the Catalog Settings dialog)? What is it set to? Increasing the size (relative to the raw image dimension) might help.

In general, rendering 1:1 preview would give you the most accurate rendition preview. The pixelation shown for non-1:1 preview is due to Lightroom rendering the preview from the lower resolution version of the negative from the camera raw cache (or Smart Preview), for performance tradeoffs.
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
The new color range mask is not applied, i make 1:1 previews on import. So your suggestions do not apply to this issue. I have to force lr to show edits in libray module.
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
I also don't have range masking applied. My standard previews are set to auto (2048). The standard previews look terrible until forcing a 1:1 build. I did not have this issue in previous versions of lightroom.
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
And to add to this, the standard previews look fine on the initial build. They only look bad once I've applied an edit in develop module.
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
Simon Chen do you have any suggestions on this issue? The previews are fine after import, then going into develop and doing edits and then returning to library means they look pretty awful (pixelated, see above examples) and if i do nothing, that preview stays like that. When i zoom in or rebuilt the preview, it updates to a smooth look
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
I just updated to classic 7.1 and found that the issue still persists. Anyone have any suggestions for trying?
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
2 images, i synced edits in Library module, zoomed in and got a screenshot before it smoothed out. Full image and the zoomed in pixelated one:
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
It's still not fixed for me either after updating to 7.1. Here is an example. The image already had a 1:1 preview built. I went into develop and applied an edit. I think switched back to library. The preview does not regenerate and looks pixelated. It only smooths out after forcing a rebuild of the 1:1 preview. Simon Chen, can you please comment? Kitty and I are both experienced lightroom users and did not experience this issue prior to classic.
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
Typo correction: "I then switched back to library."
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
Before:
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
After forcing rebuild of 1:1
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 348 Posts
  • 118 Reply Likes
Hi Kitty & Josh,
We need more info from you.
I have contacted you offline.

Thanks,
Sunil
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
Hi Sunil, do you have any news? Both Josh and I replied to your email, and i provided images with a dropbox link for you to test (not sure if Josh did too).
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 348 Posts
  • 118 Reply Likes
Yes, Kitty.
I was continuing the discussion with Josh.
Josh also shared a video with me.
We see a kind of pixelation, which is corrected by 1:1 rendering. 
It shouldn't be a new behavior we introduced recently. We are investigating.

Thanks,
Sunil