Lightroom Classic: Issue with external ssd - I can see it for import but not to use for photo storage

  • 1
  • Question
  • Updated 1 month ago
I'm having troubles getting lightroom classic to recognize my external ssd to use for photo storage. It can see the drive for importing photos, but nothing shows up in the folders column when I'm in the library page. I'm running lightroom 9.2.1, there is a photo on the drive, and I've also tried formatting the drive with all the possible options to use on my Mac. None of this seems to be working though. The drive in question is a Sandisk extreme ssd that I'm trying to use as my main storage as the computer drive is just not that big. Any help would be greatly appreciated!! 
Photo of Allen Cooper

Allen Cooper

  • 6 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of OuiOui Photo

OuiOui Photo

  • 8 Posts
  • 0 Reply Likes
In the library you will see only the drives where you have photo on but known by Lighroom.  So just import one photo and select this drive as destination and then it will appear in Lightroom after
Photo of OuiOui Photo

OuiOui Photo

  • 8 Posts
  • 0 Reply Likes
I think you misunderstood or i misunderstood ? ;) You have, in lightroom, to import one photo and to chose as a destination this drive.  Not as a source.  So to import from any source, in copy mode, to this SSD drive as a destination from lightroom
Photo of Allen Cooper

Allen Cooper

  • 6 Posts
  • 0 Reply Likes
In the midst of reformatting, I did forget to import a photo again. I just finished trying that, and unfortunately its the same result. Image has been imported, closed LR, disconnected SSD, then connected it and opened up LR again. It's still not seeing the drive. Perhaps I missed something?
Photo of Carlos Cardona

Carlos Cardona

  • 777 Posts
  • 149 Reply Likes
Did you check my suggestion, below?
Photo of OuiOui Photo

OuiOui Photo

  • 8 Posts
  • 0 Reply Likes
So after importing one photo form another source to the SSD from Lightroom you should see the SSD on the left because now you have one photo on it that is indexed by Lightroom.  Do you see it just after the importation. If you right clic on the photo you just have imported and select "Show in the finder". The finder open and show the photo on the SSD ?   Your problem is if you close LR and reopen ? In this case you don't see the SSD anymore ? But do you still see the last imported photo ? Is it missing ? 
Photo of Allen Cooper

Allen Cooper

  • 6 Posts
  • 0 Reply Likes
Looks like I was working though this when you posted. Yes! Thanks so much for your help!! So frustrating, missing such a simple task. 
Photo of Carlos Cardona

Carlos Cardona

  • 777 Posts
  • 149 Reply Likes
You don't say your Mac OS, did you recently upgrade to Catalina? If so, did you get a message "allow Lightroom to access files on a 3rd party drive"? Answer should have been Yes! If not, try this:

 Go to System Preferences > Security & Privacy > Privacy tab. Unlock the lock at the bottom with your login password. Select Files & Folders down the left hand side and make sure Adobe Lightroom Classic is listed on the right hand side, & all of its checkboxes are checked? (If Lightroom is not in the right-hand pane, just drag/drop the app there). On mine, LR has access to "Removable Volumes" and "Documents Folder". Let me know if that helped!

(Edited)
Photo of Allen Cooper

Allen Cooper

  • 6 Posts
  • 0 Reply Likes
Thanks for your help! I'm still running Mojave 10.14.6 - Didn't see the need to update just yet. The updated features didn't feel like they applied much to me and I was worried about the whole 64 vs 32 bit thing. I did take a look at my security tab, under photos LR Classic is checked off for access to photos though. 
Photo of Allen Cooper

Allen Cooper

  • 6 Posts
  • 0 Reply Likes
I'm such a dummy!

Upon trying to import another image and start the process over, I noticed (on the import page) at the bottom, below my HD option, there is option to import the photo to the SSD, which I just did. Now LR sees my external drive. Facepalm. 

I'm not entirely sure if that was the correct procedure, but it worked. lol.

Thank you both for taking the time to help me out, I really appreciate it! 
Photo of OuiOui Photo

OuiOui Photo

  • 8 Posts
  • 0 Reply Likes
Good news ;)