Lightroom Classic: Import problem with Mojave update

  • 4
  • Problem
  • Updated 2 months ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom Classic: Side panels erratically overlay import dialog (latest macos)

Since updating my iMac Pro OS to Mojave, Lightroom Classic does not display the import window. 
I have found that this only happens when using Lightroom in full screen mode. Is anyone else seeing this bug? Is there a fix?
Photo of Roberto Gonzalez

Roberto Gonzalez

  • 4 Posts
  • 1 Reply Like

Posted 8 months ago

  • 4
Photo of dmeephd

dmeephd

  • 300 Posts
  • 73 Reply Likes
I almost never use full screen mode as I use multiple 34' monitors.  However, if you provided some more information, I might have seen something like this in normal screen mode.  Which 'import' window are your referring to?  The import window when you select the source for the import and see the images which will be imported BEFORE you start the process, or the import window linked to the current import AFTER it has been started?

And what do you mean by ..."does not display..."?  Its is absent or simply empty?

I ask because under Mojave I have consistently found that no images appear in the import window which is presented after the import has been started unless and until the import is complete; the building previews continues.  I think this behavior is only due to the fact the LR 7.x performs both operations in parallel, something I never saw in LR 6.

I do see the window, but it remains empty.  Please clarify if you could.
Photo of Smit Keniya

Smit Keniya, Employee

  • 223 Posts
  • 99 Reply Likes
Hi Roberto,

I am not able to reproduce this on macOS Mojave with LrClassic in Full Screen. Could you share a video recording for the steps you are following to reproduce this? This would help us to reproduce this on our end.

Thanks,
Smit Keniya
Lightroom Classic CC Team
(Edited)
Photo of Roberto Gonzalez

Roberto Gonzalez

  • 4 Posts
  • 1 Reply Like
After rebooting several times, and importing several times I have found that this can be an intermittent problem. 

The problem is that the side panels or top and bottom panels don''t always go away when the program switches to the import window. This is BEFORE I start the process.

I have attached a video of this when I synchronized the folder. As you see the panels block the import button. My workaround is to switch out of full screen mode on my Mac. Another workaround is to close the panels before importing.
Photo of Roberto Gonzalez

Roberto Gonzalez

  • 4 Posts
  • 1 Reply Like

Photo of John R. Ellis

John R. Ellis, Champion

  • 4279 Posts
  • 1138 Reply Likes
Merging with similar topic

Please reference the new conversation here: Lightroom Classic: Import problem with Mojave update (merging)
Photo of Yves Crausaz

Yves Crausaz

  • 351 Posts
  • 50 Reply Likes
Same problem, but solution:

In the import menu, select "New Phots". and they will appear!

Même problème, mais solution :

Dans le menu d'importation, sélectionner "Nouvelle Phots". et elles vont apparaître !




#s3gt_translate_tooltip_mini { display: none !important; }
(Edited)
Photo of John R. Ellis

John R. Ellis, Champion

  • 4280 Posts
  • 1138 Reply Likes
Merging with similar topic

Please reference the new conversation here: Lightroom Classic: Import problem with Mojave update (merging)
Photo of Gerald Bracken

Gerald Bracken

  • 1 Post
  • 0 Reply Likes
I also have an import problem but I see a ghost of the import screen on the regular Library screen. If I press the Develop button I get the full Import screen. This only happens in full screen mode. I have a Late 2015 iMac w 32gb of ram.
I also have a similar problem with Photoshop superimposing screens. Anyone ideas?
(Edited)
Photo of John R. Ellis

John R. Ellis, Champion

  • 4292 Posts
  • 1139 Reply Likes
Merging with simiilar topic

Please reference the new conversation here: Lightroom Classic: Import problem with Mojave update (merging)
Photo of Bola Oshisanwo

Bola Oshisanwo

  • 1 Post
  • 0 Reply Likes
I have the same problem as Gerald. Is there a solution forthcoming?
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1932 Posts
  • 803 Reply Likes
The easiest solution is to use 'Full Screen with Menubar'. That is only slightly different from full screen and should solve this. Adobe never comments on future developments, so nobody can and will tell you when this bug is fixed.
Photo of GLYN POWELL-EVANS

GLYN POWELL-EVANS

  • 3 Posts
  • 0 Reply Likes
I have a similar issue since upgrading to Mojave. When I click on the Import button the dialog opens in the middle area but the Library panels remain open on each side and cannot be closed, so it is impossible to Import. I have tried selecting other Modules (Dev, Print etc) and sometimes this clears the Library side panels but not always. I have tried different screen modes and seen problem regardless of which selected. Restarted LR but still same issue yesterday. However tried again just now (still logged in from yesterday) and working normally.

Photo of John R. Ellis

John R. Ellis, Champion

  • 4279 Posts
  • 1138 Reply Likes
Merging with similar topic

Please reference the new conversation here: Lightroom Classic: Import problem with Mojave update (merging)
Photo of Jay Dodson

Jay Dodson

  • 1 Post
  • 0 Reply Likes
i can confirm the same problem on my system.
Photo of Matthew Zory

Matthew Zory

  • 58 Posts
  • 3 Reply Likes
I also have the problem. iMac 27", 2017 machine. Just switched to Mojave and I don't get the correct side tabs for Import as described above--so you can't do the import. Stumbled on this though---press the 'i' key...takes you to the Import module!
Photo of John R. Ellis

John R. Ellis, Champion

  • 4279 Posts
  • 1138 Reply Likes
Merging with similar topic

Please reference the new conversation here: Lightroom Classic: Import problem with Mojave update (merging)

This conversation is no longer open for comments or replies.