Lightroom Classic: Crashing

  • 1
  • Problem
  • Updated 6 months ago
  • Solved
  • (Edited)
Lightroom Classic keeps crashing when in develop. No filmstrip goes black. I have uninstalled and reloaded several times. No tec support . Very frustrated at this point...
Photo of Iona Laird

Iona Laird

  • 1 Post
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Carlos Cardona

Carlos Cardona

  • 238 Posts
  • 42 Reply Likes
LR Classic runs on top of an OS. Think maybe the OS might be the issue. Not everyone runs the OS you're running, which one is it?
Photo of Tony Bell

Tony Bell

  • 2 Posts
  • 1 Reply Like
I'm having the same (or very similar) problem following the upgrade to Classic from CC and rebuilding catalogs.  I'm running on 64 bit Windows 10.  URGENTLY NEED to process images today, how can I reverse the upgrade??
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1666 Reply Likes
First, try updating your graphics driver. 

If that doesn't work, try this workaround to see if it works for you. If not, delete the config.lua file afterwards.
  1. Choose Edit > Preferences.
  2. In the Preferences dialog, go the Presets tab.
  3. In the Presets tab, click the Show Lightroom Presets Folder button. The root preset folder opens in the File Explorer. 
  4. In the File Explorer, navigate into the Lightroom folder.
  5. Go to the link https://adobe.ly/2hUHGYa and download the config.lua file. Copy the downloaded config.lua file into the Lightroom folder mentioned in the previous step.
  6. Relaunch Lightroom Classic CC.
The System Info dialog (Help > System Info) should display the config.lua flags entry as shown below:

Config.lua-Flags:
AgView.disableDirect2D = true
Photo of Tony Bell

Tony Bell

  • 2 Posts
  • 1 Reply Like
Thank you Jeffrey - once for the prompt response and then again for hitting the nail on the head in your opening line.  Updated the graphics drive and all is well.

Tony :-)