Lightroom Classic: Crashes on launch again

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
Started Lr Classic 8.2.1 today and Lr is back to its old problem of crashing again on launch. It was fine yesterday. Have submitted the crash report, but I'm losing count of how many times this has happened.

I've worked out how to get Lr working again, so why can't the software 'engineers' work out how to fix it?
Photo of Anthony Blackett

Anthony Blackett

  • 138 Posts
  • 49 Reply Likes
  • Disappointed

Posted 2 months ago

  • 1
Photo of SatishT

SatishT, Employee

  • 84 Posts
  • 31 Reply Likes
Hi Anthony,

I could not find any crash reported by you associated with your email id(on feedback.photoshop.com).
The next time Lr crashes, add your email id to the crash report so that we can identify the crash report and try to figure out what is the issue?

-Satish
Photo of Anthony Blackett

Anthony Blackett

  • 136 Posts
  • 49 Reply Likes
Satish, my email is a.blackett@physics.org
Photo of SatishT

SatishT, Employee

  • 84 Posts
  • 31 Reply Likes
Found the crash report. We will analyze the crash report and get back to you if we need any further information.
Photo of Carlos Cardona

Carlos Cardona

  • 427 Posts
  • 89 Reply Likes
Maybe it’s the OS? Mac or Windows?
Photo of Anthony Blackett

Anthony Blackett

  • 138 Posts
  • 49 Reply Likes
Update: I'm using Windows 10. Information from Adobe and the crash report has pointed to a peripheral device. I have isolated it to my Samsung Galaxy Tab S 10.5 causing the issue. When it is plugged into my computer's USB port, which I did this morning, Lr crashes. Unplug the tablet and Lr doesn't crash.

At least I now know what the cause is and how to prevent it.

Thank you again Satish.
Photo of Anthony Blackett

Anthony Blackett

  • 138 Posts
  • 49 Reply Likes
I have now resolved this issue by uninstalling the Samsung Mobile USB Composite Device driver, including the driver files for the device, disconnecting, then reconnecting the tablet to allow Windows to reinstall the driver. I've been running Lr Classic for over an hour now with the tablet plugged in. No more crashes.

Fixed at last.
Photo of Anthony Blackett

Anthony Blackett

  • 138 Posts
  • 49 Reply Likes
Damn, not fixed. Didn't see the tablet requesting to allow the connection with the computer. Once I allowed the connection, Lr crashed.

So, still a problem there somewhere.
Photo of Carlos Cardona

Carlos Cardona

  • 427 Posts
  • 89 Reply Likes
"Windows is a collection of device drivers, Mac is an operating system". I've supported both as an IT Engineer, Macs are way less troublesome (you can read the studies). Uninstall the device driver again and contact Samsung with a bug report.