Lightroom Classic Collection Sync to LR Mobile for Android Color Management Issue

  • 1
  • Problem
  • Updated 6 months ago
  • Acknowledged
  • (Edited)
I'm using LR Classic 8.2.1 with LR CC Mobile for Android 4.2.2 to upload
smart previews to Cloud storage and then download them to LR Mobile for Android on my Samsung Note Pro tablet. I've also installed LR Mobile Desktop to get my custom camera profiles uploaded, but no editing in LR Mobile Desktop has been performed.

I can review pictures in my LR Classic synced albums in LR CC Mobile for Android, LR CC Web and LR CC Desktop. However, if I try to review the pictures on my Samsung tablet with WiFi disconnected I get a message on some image files 'Failed to load Development version.' So it appears only some of the LR Classic synced smart previews are being downloaded onto the Samsung internal storage. I'm certain this was working properly at one time, but not any longer.

I've uninstalled LR Mobile on my Samsung tablet including deleting all application data and cache and reinstalling with no change in behavior. I've also created a new synced collection in LR Classic and it exhibits the same behavior in LR Mobile for Android on my Samsung tablet.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1574 Posts
  • 534 Reply Likes
  • The Gap is Widening....Why!

Posted 6 months ago

  • 1
Photo of Todd Shaner

Todd Shaner, Champion

  • 1574 Posts
  • 534 Reply Likes
Found the solution, which is to enable 'Store Locally' in Albums view (see below). I don't recall doing this when I first started using LR CC Mobile for Android quite some time ago. It works now when Wi-Fi is disabled, but when browsing images there is about a 1 sec. delay before it is fully sharp. That was not the case when I first started using LR Mobile for Android on this same Samsung Note Pro tablet over a year ago. So it is working properly now, but why is there a 1 sec. lag in getting a fully sharp screen rendering? I also notice a small spinning beach ball icon in the middle of the image that disappears after ~4 sec. If I click on the 'i' information icon in the lower right corner of the preview window the icon does not appear, but it still takes 1 sec. before the image is fully sharp. The tablet is a Samsung Galaxy Note Pro 12.2" model SM-P900 32GB Wi-Fi.

https://helpx.adobe.com/lightroom-cc/using/work-with-lightroom-mobile-android.html

The Albums view is a listing of all the albums and folders that you either created in Lightroom for mobile (Android), or synced from Lightroom desktop or Lightroom Classic.Additionally, in the Albums view tap the () icon next to a shared album name and perform any of these operations:
  • Add Photos - Select this option to add photos to the album you are in.
  • Store Locally - Select this option to locally store the photos contained in the album you are in.
Just discovered with the above setting, image files downloaded onto the tablet, and Wi-Fi turned ON there is NO delay in rendering a fully sharp screen image! The spinning beach ball icon is still there when not in the 'i' information display mode. There's no question that the files are downloaded to the tablet's local storage so why does having Wi-Fi on even matter?
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 1574 Posts
  • 534 Reply Likes
After reviewing this further it appears there is a long-standing color management issue with LR Mobile for Android. See this post: https://forums.adobe.com/message/10230688#10230688

What I'm actually seeing on my Samsung Note Pro is an initial image rendering that is slightly under-saturated and after about 4 sec. the rendering becomes noticeably over-saturated. When viewing the same files using LR CC Web with color managed Chrome browser the colors are correct and very closely match what I see in LR Classic and CC Desktop on my Windows 10 system with a NEC PA272w calibrated monitor.

The 4 sec. image rendering delay appears to be due to a background color profile conversion process, which is most likely the root cause of the issue. This is NOT observed when viewing the same albums in LR Web. I ran tests using both raw files with Adobe Standard camera profile and TIFF files that use no camera profile. The same behavior was observed with both the raw and TIFF files exhibiting the same 4 sec delay and color shifts.

Here's a video screen capture of the issue on my Samsung Note Pro 12.2" tablet running  Lollipop 5.1 with an album created in LR CC 2.2.1. Some of the files are 2560 Long Edge JPEG export files and some are CR2 raw files. They ALL exhibit the same color shift issue and 4 sec. delay for full render as my collections synced using LR Classic 8.2.1. So this is NOT just a LR Classic issue–It is specifically a LR Mobile for Android issue regardless of how the image files enter the LR CC ecosystem.

NOTE: All LR Classic and CC Desktop created albums display correct color with no delay issues using LR Web (lightroom.adobe.com) in color managed Chrome and FireFox browsers.

When reviewing synced albums using LR Mobile for Web with color managed Firefox (v66.0.3) browser there is no delay in rendering, but the image appears slightly under-saturated. However, when clicking on ‘Edit this Photo’ the image appears over-saturated on my wide gamut monitor. This appears to be due to the monitor’s display profile being bypassed. Chrome (73.0.3682) browser does not exhibit the issue.



https://www.dropbox.com/s/8dqt8tiwpg2z2qr/2019_04_29_09_05_49_0001_Cut.mp4?dl=0


(Edited)